Opened 8 years ago

Closed 8 years ago

#1001 closed help (fixed)

Merge branch problem

Reported by: cplanche Owned by: ros
Component: FCM Keywords: merge, branch
Cc: Platform: PUMA
UM Version: 7.7

Description

Hello,

I used the nesting suite procedure to do some studies. In order to do an other sensitivity study, I created a branch:

fcm:um_br/dev/cplanche/vn7.7_no_ice 

I tried to submit the xialb job to create the executable but it failed during the extract step. It seems that there is a conflict between my new branch and the default one used in the nesting suite procedure (I enclosed the ext.out file):

fcm:um_br/dev/pfield/VN7.7_MY_7.7_PS26_Glob_Conf

So, I tried to merge the two branches but this step doesn't work. The error message is:

cplanche@puma:~/FCM> cd vn7.7_no_ice
cplanche@puma:~/FCM/vn7.7_no_ice> fcm info
Path: .
URL: svn://puma/UM_svn/UM/branches/dev/cplanche/vn7.7_no_ice
Repository Root: svn://puma/UM_svn
Repository UUID: 8ca64e62-1750-0410-b9b8-f1ff413d6028
Revision: 10409
Node Kind: directory
Schedule: normal
Last Changed Author: cplanche
Last Changed Rev: 10409
Last Changed Date: 2012-12-13 10:22:58 +0000 (Thu, 13 Dec 2012)

cplanche@puma:~/FCM/vn7.7_no_ice> fcm merge fcm:um_br/dev/pfield/VN7.7_MY_PS26_Glob_Conf
[FAIL] svn://puma/UM_svn/UM/branches/dev/pfield/VN7.7_MY_PS26_Glob_Conf: not a valid URL
.

Why the URL of the branch is not valid? Did I do something wrong?

Many thanks.
Celine

Attachments (1)

ext.out (104.0 KB) - added by cplanche 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by cplanche

comment:1 Changed 8 years ago by ros

  • Status changed from new to accepted

Hi Celine,

What you are doing is absolutely correct, all that is wrong is a typo in the merge command. The branch URL is missing a 7.7

fcm merge fcm:um_br/dev/pfield/VN7.7_MY_7.7_PS26_Glob_Conf

Cheers,
Ros.

comment:2 Changed 8 years ago by cplanche

Hi Ros,

Sorry for this stupid problem.
Many thanks.

Celine

comment:3 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

No worries.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.