Opened 8 years ago

Closed 8 years ago

#1005 closed help (worksforme)

Xancil error - Cannot read date from NetCDF file

Reported by: luke Owned by: jeff
Component: UM Tools Keywords: Xancil,netCDF
Cc: Platform: Other
UM Version: <select version>

Description

I'm attempting to make up some SST and Sea-Ice ancillaries using HadGEM2-ES data downloaded from the ESGF data node. Xancil can make up ancillaries using monthly data, but it's having a problem with the daily SST (tos) data. The error produced by Xancil is

 ERROR: Cannot read date from NetCDF file /scratch/nla27/CMIP5/daily/tos_day_HadGEM2-ES_rcp45_r1i1p1_20810101-21001230_ydm_N48.nc as it has no time dimension

If I try to specify the dates manually I get the following error:

 ERROR: Can only specify 1 time in xancil as file /scratch/nla27/CMIP5/daily/tos_day_HadGEM2-ES_rcp45_r1i1p1_20810101-21001230_ydm_N48.nc has no time dimension

When I ncdump'd this file, I get:

netcdf tos_day_HadGEM2-ES_rcp45_r1i1p1_20810101-21001230_ydm_N48 {
dimensions:
        longitude = 96 ;
        latitude = 73 ;
        time = UNLIMITED ; // (360 currently)
variables:
        float longitude(longitude) ;
                longitude:standard_name = "longitude" ;
                longitude:long_name = "longitude" ;
                longitude:units = "degrees_east" ;
                longitude:axis = "X" ;
        float latitude(latitude) ;
                latitude:standard_name = "latitude" ;
                latitude:long_name = "latitude" ;
                latitude:units = "degrees_north" ;
                latitude:axis = "Y" ;
        double time(time) ;
                time:standard_name = "time" ;
                time:units = "days since 1859-12-01 00:00:00" ;
                time:calendar = "360_day" ;
        float tos(time, latitude, longitude) ;
                tos:long_name = "Sea Surface Temperature" ;
                tos:units = "K" ;
                tos:_FillValue = 2.e+20f ;
                tos:source = " " ;
                tos:name = "tos" ;
                tos:title = "Sea Surface Temperature" ;
                tos:date = "01/12/59" ;
                tos:time = "00:00" ;

// global attributes:
                :CDI = "Climate Data Interface version 1.5.4 (http://code.zmaw.de/projects/cdi)" ;
                :Conventions = "CF-1.4" ;
                :history = "Wed Jan 02 15:45:07 2013: cdo setclonlatbox,271.35,0.0,360.0,88.0,90.0 tos_day_HadGEM2-ES_rcp45_r1i1p1_20810101-21001230_ydm_N48_nopole.nc tos_day_HadGEM2-ES_rcp45_r1i1p1_20810101-21001230_ydm_N48.nc\n",
                        "Wed Jan  2 15:42:00 GMT 2013 - XCONV V1.91 16-February-2006" ;
                :CDO = "Climate Data Operators version 1.5.4 (http://code.zmaw.de/projects/cdo)" ;
}

I initially thought that the fact the time dimension in this file is double while the rest are float may have caused problems, but manually setting this dimensions to float using ncap and using ncatted to add the time attributes back still gives the same error.

It should be noted that Xconv can read this file, and in fact created it. Making up the Sea-Ice from the daily sic data also seems to work, and this file also only has 3 dimensions (time,latitude,longitude).

I'm using Xancil 0.50 (23-September-2009) and Xconv 1.91 (16-February-2006).

Any advice would be greatly appreciated.

Many thanks,

Luke

Change History (2)

comment:1 Changed 8 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Luke

I tried xancil with your data and didn't find the problems you are getting. Can you make sure you are using the latest version of xancil (0.53), you can copy it from hector.

Jeff.

comment:2 Changed 8 years ago by grenville

  • Resolution set to worksforme
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.