Opened 6 years ago

Closed 6 years ago

#1007 closed error (fixed)

"Unable to locate a modulefile": MetUM error at vn7.3

Reported by: sosprey Owned by: ros
Component: NEMO/CICE Keywords: MONSooN, NEMO/CICE, modulefile
Cc: Platform: MONSooN
UM Version: 7.3

Description

Hello,

I am running a job at vn7.3 on MONSooN and am geeting the following error:

ModuleCmd_Load.c(200):ERROR:105: Unable to locate a modulefile for 'xlc/v10.1.0.0'

I have been told that I may need to get explicit access to the NEMO/CICE repository for the job I am running. Is the error consistent with this?

ciao,
Scott.

Attachments (1)

xgrzc000.xgrzc.d13022.t155853.comp.leave (88.8 KB) - added by sosprey 6 years ago.
.comp.leave file for job xgrzc

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by sosprey

.comp.leave file for job xgrzc

comment:1 Changed 6 years ago by willie

H Scott,

You can ignore this error - I get them too. It's nothing to do with NEMO/CICE

Regards

Willie

comment:2 Changed 6 years ago by ros

Hi Scott,

Just to add to what Willie has said. You automatically have read access permissions to the NEMO/CICE repository so any job you run will be able to extract ok from the NEMO/CICE repository. If you require to modify the NEMO/CICE code let me know and I can give you write permissions.

Regards,
Ros.

comment:3 Changed 6 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Ros,

I think permissions may be my problem. In the .leave file I attached in
the initial ticket-query it states:

Creating directory /um/xgrzc
Cannot create /um.
/um: Permission denied
Creating directory /um/xgrzc
Cannot create /um.
/um: Permission denied

The .leave file then describes other files not being found within these
directories. Would these permissions you speak of be relevant here?

One last thing, I was not sure how to add to the ticket thread as there is no obvious switch on the ticket website. That is why I have emailed you rather than going through the proper channels, whatever they may be.

ciao,
Scott.

comment:4 Changed 6 years ago by ros

Hi Scott,

The "Cannot create /um" error I presume is supposed to be trying to create $DATADIR/um, but some variable isn't set. I'll take a look at your job and see if I can see what is going on.

To add to a ticket you just need to login to the Helpdesk, find your ticket and then enter your response in the "Add comment" field near the bottom of the page displaying your ticket.

Cheers,
Ros.

comment:5 Changed 6 years ago by ros

Hi Scott,

Do you have $WORKDIR defined anywhere? I can't find it. It doesn't appear to be set in your job or in your .profile either so when it comes to create $WORKDIR/um/bin it's trying to create /um/bin.

Cheers,
Ros.

comment:6 Changed 6 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.