Opened 7 years ago

Closed 7 years ago

#1017 closed help (fixed)

First attempt running of UKCA job: it is not submitted

Reported by: fcentoni Owned by: ros
Component: UM Model Keywords:
Cc: luke Platform: HECToR
UM Version: 7.3

Description

Dear NCAS Staff,
my name if Federico Centoni (puma UN fcentoni). I tried to run a copy of the UKCA job Tropisop N48L60 (xiepb) but it does not work. I just changed the general details with my username and email address and then I targeted the system to the Hector machine and I put my used id fcentoni.
Then I went to the 'FCM configuration and in FCM extract and build directories and output levels' I changed the local machine root extract directory in $home/fcentoni and the target machine root in : /home/n02/n02/fcentoni.
Furthermore, I changed the run length in 1 year.
I processed it and when I submit the job I get:

FCM_MAIN: calling extract
creating directory /fcentoni/xieb/unbase
mkdir: cannot create fcentoni: permission denied

creating directory /fcentoni/xiepb/unmodel
mkdir: cannot create directory /fcentoni: permission denied

creating directory /fcentoni/xiepb/unrecon
mkdir: cannot create directory fcentoni: permission denied

/home/fcentoni/umui_jobs/xiepb/FCM_EXTR_SCR
/home/n02/n02/fcentoni/xiepb/umbase/ext.out: cannot create[no such file or directory]

I do not if I have done something wrong with paths.
Many thanks,
Federico.

Attachments (7)

EXT_SCRIPT_LOG (4.4 KB) - added by umdoc 7 years ago.
Job script
FCM_EXTR_SCR (3.3 KB) - added by umdoc 7 years ago.
FCM script
FCM_MAIN_SCR (2.5 KB) - added by umdoc 7 years ago.
FCM Main script
xiepb000.xiepb.d13043.t161134.comp.leave (90.2 KB) - added by fcentoni 7 years ago.
Compilation file of the job xiepb from /um/umui_out Hector dir
xiepb000.xiepb.d13043.t161134.comp.2.leave (90.2 KB) - added by fcentoni 7 years ago.
Compilation file of the job xiepb from /um/umui_out Hector dir
xiepb000.xiepb.d13044.t135954.leave (185.2 KB) - added by fcentoni 7 years ago.
New compilation file job xiepb
xiepd000.xiepd.d13049.t120939.comp.leave (91.9 KB) - added by fcentoni 7 years ago.
xiepd job compilation file

Download all attachments as: .zip

Change History (57)

Changed 7 years ago by umdoc

Job script

Changed 7 years ago by umdoc

FCM script

Changed 7 years ago by umdoc

FCM Main script

comment:1 Changed 7 years ago by luke

  • Resolution set to fixed
  • Status changed from new to closed

Hi Federico,

The issue here that the path settings in

Model Selection -> FCM Configuration -> FCM Extract and Build directories and Output levels

have become a little confused. Suggested values are:

For your

UM_OUTDIR: $HOME/um/um_extracts

this means that the source code will be extracted to the um/um_extracts in your home directory on PUMA. In Linux, $HOME will be set automatically to your home directory (on PUMA, this is /home/fcentoni, whereas on HECToR it would be /home/n02/n02/fcentoni). There is no $home environment variable and so the system would read this as nothing.

For your

UM_ROUTDIR: /home/n02/n02/fcentoni/um

where the username here is your HECToR username (in your case, this is the same as your PUMA username).

For your

FCM Extract output will be sent to: $UM_OUTDIR/ext.out

i.e. it is placed in your extract directory on PUMA.

A good example of the suggested settings is in ukca job xfvfc, except for changing your username from 'dummy' in UM_ROUTDIR no other changes need to be made.

Can you make these changes and try to submit the job again?

Also, you have submitted this ticket using the umdoc user - you should instead log-in with your own username and password to the helpdesk. If you are still having problems can you please open a new ticket in that way. I will close this ticket now.

Thanks,

Luke

comment:2 Changed 7 years ago by ros

  • Reporter changed from umdoc to fcentoni

Hi Federico,

Please make sure that you log into the Helpdesk using your Helpdesk username fcentoni and not the generic umdoc as you will not receive any email updates to your query. I thought I'd prevented umdoc from creating tickets, but obviously not. :-( I will fix this as soon as I can.

Luke has just replied to you but you will need to look at the ticket here http://cms.ncas.ac.uk/ticket/1017 to see the response.

Also for the future could you please change the permissions on your HECToR directories so that we can see your files by running the following commands:

chmod -R g+rX /home/n02/n02/fcentoni
chmod -R g+rX /work/n02/n02/fcentoni

Regards,
Ros.

comment:3 Changed 7 years ago by fcentoni

Hi Luke

I have changed the paths as suggested above and then I tried to run both the same job xiepb I had been submitting before and another job xiepd, copy of Paul Telford UKCA 7.3 get running.
The processing seems ok but when I submit both the job the system gets stuck again:

FCM_MAIN: calling extract
Base extract: failed
see extract outfile
/home/fcentoni/um_extractsxiepd/umbase/extract
FCM_MAIN: extract failed
tidying up directories…

I also executed both chmod instructions lines as above.

Many thanks again,
Federico

comment:4 Changed 7 years ago by ros

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi Federico,

It looks like your ssh isn't set up correctly. You need to make sure that you can login from PUMA to HECToR without a prompt for either a password or passphrase.

Instructions can be found here:
https://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/Ros/sshAgent

Regards,
Ros.

comment:5 Changed 7 years ago by fcentoni

Hi Ros,

Still not working. I get the same message above but instead of the hector password now I am asked to enter the passphrase for /.ssh/id_dsa ….

About the instructions mentioned in the link above I think I correctly did the point 1) to 4).
About the point 5.1, in my setup script /home/fcentoni/.ssh/ssh-setup I changed the line:

SSH_ENV= $HOME/.ssh/environment.'hostname' —> /home/fcentoni/.ssh/environment.puma

Then,for the point 5.2, in the file .profile, within my home, I added the line:

. /home/fcentoni/.ssh/ssh-setup after (### PLEASE ADD YOUR CODE BELOW THIS LINE ###)

Finally,
I sshed to fcentoni@… and I entered my passphrase as requested.

I am sorry but I am not familiar with these configuration troubles so many thanks again for you help.
Federico.



comment:6 Changed 7 years ago by ros

Hi Federico,

Re point 5.1 - You don't need to edit anything in the ssh-setup script please leave the line

SSH_ENV= $HOME/.ssh/environment.'hostname'

as it was. 'hostname' is automatically replaced with the name of the host it is being run on.

I suspect the problem is that you haven't run "ssh-add" as detailed in point 6? This attaches your ssh-key to the ssh-agent.

Cheers,
Ros.

comment:7 Changed 7 years ago by fcentoni

Hi Ros,

I fixed my mistakes about the scripts.
About the 6) point if I type: ssh-add , I get:
"Could not open a connection to your authentication agent".

Thank you,
Federico


comment:8 Changed 7 years ago by ros

Hi Federico,

Please delete the file ~/.ssh/environment.puma if it exists. Then log out of PUMA and back in again. You should hopefully see a message something like "Initialising new ssh-agent". Then run ssh-add and you will then be prompted for your passphrase. If all that completes successfully, try logging in to HECToR from PUMA and you should not be prompted for a password or passphrase.

Regards,
Ros.

comment:9 Changed 7 years ago by fcentoni

Hi Ros,
I deleted the file environment.puma, then I logged out and logged in again.
Then this is what I get:
/home/fcentoni/.profile[21]: .[18]: /home/fcentoni/.ssh/environment.hostname: not found [No such file or directory]
Initialising new SSH agent…
/home/fcentoni/.profile[21]: .[24]: : cannot open
chmod: missing operand after `600'
Try `chmod —help' for more information.
Usage: . [ options ] name [arg …]

I tried to ssh-add typing:
ssh-add ~/.ssh/id_dsa
I get:
Could not open a connection to your authentication agent.

Many thanks for your patience.

comment:10 Changed 7 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from reopened to accepted

Hi Federico,

Probably best to just recopy the ssh-setup script from the website (http://climate.ncas.ac.uk/ssh/ssh-setup) and replace the one you already have.

Once you've done that log out of PUMA and back in again. You should then have no errors in that script and hopefully you will then be able to run ssh-add successfully.

Regards,
Ros.

comment:11 Changed 7 years ago by fcentoni

Hi Ros,

it seems that ssh-agent trouble is fixed. Now, running the job xiepb, this is what I get submitting it:

FCM_MAIN: Calling Extract…
Base extract: OK
Model extract: OK
Reconfiguration extract: OK
FCM_MAIN: Extract OK

FCM_MAIN: Submitting umuisubmit_clr…
qsub: script file:: No such file or directory
FCM_MAIN: Submit failed

PathScale? PrgEnv? loaded
xtpe-network-gemini
PrgEnv?-pathscale/4.0.46
xt-mpich2/5.3.4
pathscale/4.0.9
xtpe-interlagos
umui_runs/xiepb-042124546/SUBMI[19]: . :
/work/n02/n02/hum/vn7.3/pathscale/scripts/.umsetvars_7.3:
cannot open[ NO such file or directory]

So the submit doesn't get completed.
Thanks,
Federico

comment:12 Changed 7 years ago by ros

In your $HOME/.profile on HECToR please change the lines

TARGET_MC=pathscale
UMSETUP=$UMDIR/setvars_4.5; export UMSETUP

to be

TARGET_MC=cce
UMSETUP=$UMDIR/setvars_7.3; export UMSETUP

Then try resubmitting the job.

Regards,
Ros.

Last edited 7 years ago by ros (previous) (diff)

Changed 7 years ago by fcentoni

Compilation file of the job xiepb from /um/umui_out Hector dir

Changed 7 years ago by fcentoni

Compilation file of the job xiepb from /um/umui_out Hector dir

comment:13 Changed 7 years ago by fcentoni

Dear NCAS Staff,

I finally managed to get trough the submitting process but it seems there still is some configuration error to cope with. Yesterday I submitted twice the job xiepb and the job xiepd just one time.
The model just come out with compilation files into the dir /um/umui_out and it didn't come out with any model output files at all.
According to the Hector Staff, there should be some configuration error in the file .profile.

Many thanks. Regards,
Federico.

comment:14 Changed 7 years ago by ros

Hi Federico,

Having just looked at these 2 jobs in the UMUI I can see they are both configured for running on Phase2b of HECToR NOT Phase3. This is why you are encountering compilation problems. You either need to get hold of jobs that are already configured for running on Phase3 which I guess Paul Telford will have OR you need to change the jobs for Phase3.

You definitely need to add a couple of compile override files:

Go to UMUI window Compile and Modifications → UM User Override Files

Check the boxes marked "Include the following list of user machine overrides" and "Include the following list of user file overrides" and enter the files:

machine override:
/home/umui/overrides/hector_cce_7.3_machine

user file override:
/home/umui/overrides/hector_cce_7.3_file

I think that should be it, but full instructions on converting a Phase2b job to Phase3 are available here: Hector/Phase3?

Regards,
Ros.

comment:15 Changed 7 years ago by fcentoni

Hi Ros,

I made the changes you mentioned and then I had a look instructions on converting a Phase2b job to Phase3 turning on 'Force full build' within FCM Extract directories and Output.
I submitted but the Submission of jib xiep.b comes out again with the message:

umui_runs/xiepb-044111957/SUBMIT[13]: .[38]: loadcomp: not found [No such file or directory]

I found a similar message within the new compilation file xiepb000.xiepb.d13044.t110327.comp.leave.
Do I have to change anything else within the file .profile?

Many thanks. Regards,
Federico

comment:16 Changed 7 years ago by ros

  • Cc luke added

Hi,

The loadcomp error has no effect on the compilation of the job. However, if you want to get rid of it add the following 2 lines before the loadcomp $TARGET_MC line in your HECToR .profile.

So you have

. /etc/profile
. /etc/bash.bashrc
loadcomp $TARGET_MC

The actual problem can be found near the end of the .comp.leave file:

 IF (L_OASIS3) THEN
ftn-7212 crayftn: WARNING U_MODEL, File = /home/n02/n02/fcentoni/um/xiepb/ummodel/ppsrc/UM/control/top_level/u_model.f90, Lin
e = 4589 
  Variable "l_oasis3" is used before it is defined.

I'm copying Luke in on this now as he may know straight-away what the problem is and how to fix it.

Cheers,
Ros.

comment:17 Changed 7 years ago by luke

Hi Federio, Ros,

I don't think that L_OASIS3 warning is the issue here, but the

ftn-7991 crayftn: INTERNAL ASAD_CHEMICAL_DIAGNOSTICS, File = /home/n02/n02/fcentoni/um/xiepb/ummodel/ppsrc/UM/atmosphere/UKCA/asad_chem_flux_di
ags.f90, Line = 8361 
  INTERNAL COMPILER ERROR:  "unexpected type in TYPE_DEREF" (v_expr_obj.c 87117, line 751)
fcm_internal compile failed (256)

which can be solved by including the

/home/ukca/comp_overides/hector_cce_7.3_asad_chem_diags

user override file. To do this go to

Model Selection
  -> Compilation and Modifications
    -> UM User Override Files

and in the bottom table (list of user file overrides) add the above to the second column (full path name) with a Y in the third column (Include Y/N). You said above that you copied one of Paul Telford's job - this must have been an older one since it wasn't configured to run on HECToR Phase 3. In addition to Ros's description above a further change needs to be made so that UKCA will compile properly on the Phase3 machine.

For further information on getting UKCA to run please see http://www.ukca.ac.uk/wiki/index.php/Bugfixes .

Thanks,

Luke

comment:18 Changed 7 years ago by fcentoni

Hi,

something good happened but HECTOR is still not properly compiling the job I submit.
I had a look to the output file xiepb000.xiepb.d13044.t130526.leave that for the first time come out into /um/umui_out/

there's this message:
/var/spool/PBS/mom_priv/jobs/1105755.sdb.SC[83]: .: /vn7.3/cce/scripts/.umsetvars_7.3: cannot open [No such file or directory]

Many thanks,
Federico.

comment:19 Changed 7 years ago by ros

Hi,

It's a mistake in your HECToR .profile…

You need to export the variable UMDIR, you've set it but not exported it.

export UMDIR=/work/n02/n02/hum

Cheers,
Ros.

Changed 7 years ago by fcentoni

New compilation file job xiepb

comment:20 Changed 7 years ago by fcentoni

Hi Ros,

it seems this time Hector compiled properly but it still doesn't come out with any output files
I attach the last compilation file I got xiepb000.xiepb.d13044.t135954.leave.

It looks like Hector doesn't like some output paths.

Many thanks again. Regards,
Federico

comment:21 Changed 7 years ago by ros

Hi,

Another error in .profile I'm afraid.

To make things easier to read can you replace the following 3 lines:

UMDIR=/work/n02/n02/hum
TARGET_MC=cce
UMSETUP=$UMDIR/setvars_7.3; export UMDIR=/work/n02/n02/hum

with

export UMDIR=/work/n02/n02/hum
TARGET_MC=cce
VN=7.3
UMSETUP=$UMDIR/vn$VN/$TARGET_MC/scripts/.umsetvars_$VN

You need to run the .umsetvars_7.3 to set environment variables used by your job.

Regards,
Ros.

comment:22 Changed 7 years ago by ros

Oh and forgot to say you will need to sumbit to recompile because it was the last part of the compilation step that failed. As it had a missing environment variable it couldn't do the copy across of the executables.

Changed 7 years ago by fcentoni

xiepd job compilation file

comment:23 Changed 7 years ago by fcentoni

Dear Ros,

thank you and Luke very much for helping me out. I managed to get some output files which I am still looking at.
Today I was trying to run another Paul Telford job xiepd but there is some trouble with the compilationn process. In attached you can find the compilation file.
Is there any chance that the problem might be related to the target machine? This beacuse the orginal target machine was login.hector.ac.uk.
Many thanks. Regards,
Federico.

comment:24 Changed 7 years ago by ros

Hi Federico,

You need to specify the Phase3 compile override files, as advised above.

Cheers,
Ros.

comment:25 Changed 7 years ago by fcentoni

Hi Ros,

I made the changes on the compile override files but the model build failed for some compilation troubles. Can you help me out to fix them?
I was also wondering if you or Luke have some document which I can look at in order to learn how to cope with these configuration and compilation troubles.
You can find the compilation file xiepd000.xiepd.d13049.t154922.comp.leave which the model came out with into the folder /home/n02/n02/fcentoni/um/umui_out. I couldn't attach it because it is too weight.
Many thanks. Regards,
Federico.

comment:26 Changed 7 years ago by ros

Hi Federico,

You're missing the other user file override:

/home/umui/overrides/hector_cce_7.3_file 

This will fix the compile problems you are seeing. All the problems you are have seen with the compilation are because you are using a job that was configured to run on HECToR Phase2b.

Unfortunately, it is really hard to document problems with compilation and configuration as they vary so greatly, it is something that comes with experience. We do have documents on the cms website on how to convert from Phase2b to Phase3 which I linked to above and setting up your environment as part of the UM FCM Tutorial.

Cheers,
Ros.

comment:27 Changed 7 years ago by fcentoni

Hi Ros,

I am having a trouble with the compliation of a copy of Ptelford's job (xiepd). Looking at the compilation file xiepd000.xiepd.d13050.t110853.comp.leave, I found:

UM ERROR (Model aborting) :

Routine generating error: INITIAL
Error code: 106
Error message:

INANCILA : Wrong calendar set in Ancillary File

Do I have to make any changes in the following sections?

input/output control resources → time convection SCRIPT and environment variables or Ancillary reference time

Many thanks. Regards,
Federico.

comment:28 Changed 7 years ago by ros

Hi Federico,

This job is set up for a 360day calendar (Input/Output control and resources → General configuration and control), but your Sea Surface Temperature ancillary file is for a 365day calendar.

Regards,
Ros.

comment:29 Changed 7 years ago by luke

Hi Federico,

I've talked with Paul Telford about your error. As Ros says, the issue here is that the model is using a 360-day calendar, but the SSTs are 365.

We're not sure which job of Paul's that you took, but the likelihood is that this job never worked, and he was doing some debugging for someone else.

Can I suggest that, while you are learning how to use UKCA, you stick with a N48 job, preferably one of the release jobs available under the ukca user in the UMUI. If you need something more specific (e.g. higher resolution, different schemes used etc) then please contact us to suggest/create a job for you to use. This way, when problems arise, we can directly diff with our original job to get solutions/suggestions. This would also prevent the issues you had with override files, since any job provided would be tested on HECToR prior to be being handed over.

If you need a N96 job please let me know and I can suggest the best one for you to take.

Thanks,

Luke

comment:30 Changed 7 years ago by fcentoni

Hi Ros (cc Luke),

Thank you very much for your advices. I will treasuring them up and hopefully I think I am learning a lot from them.
The job of Ptelford I was trying to run was xflna.
Actually, I have been trying to run the job xiepc (copy the job xiepb, the one we turned into a phase3 job) which it seems it was properly compiled.
My purpose is to run the base model with the dry deposition scheme on and to evaluate how it performs comparing the results (once I got them) with other models. This in order to estimate what's the current potencial of UKCA in terms of estimating dry deposition fluxes so that I could target future devolopments through different parameterizations. So actually, at the moment it would be ok to use a working release job.
I have a doubt. If I switch on the UKCA dry deposition scheme clicking on COUPL button, should I expect other diagnostics to appear in STASH?
Within the section 34 of STASH, for the diagnostics Ox budget: 03 dry deposition (2D) and NOy dry deposition (2D), does 2D stand for 2D scheme which is supposed to be the default one. I am sorry, but it is not so clear to me which dry deposition scheme is on.

Looking at the last compilation file xiepc000.xiepc.d13052.t113948.leave, it turnes out the job run terminated normally. Can you confirm me that everything is ok so that I could resubmit the job and going on with the run?

Many thanks. Cheers,
Federico.

comment:31 Changed 7 years ago by luke

Hi Federico,

I'm currently in the process of making up a new job for you which contains all the updates to the Wesely interactive dry deposition scheme, as well as corrections to the STASHmaster files which will allow 3D output of diagnostics. I'll let you know when this job is ready for use.

Thanks,

Luke

comment:32 Changed 7 years ago by fcentoni

Hi Ros,

I was trying to risubmit a job (xipc) that was finally run.
As suggested by my supervisor David Stevenson, he told to change the lines TYPE=NRUN → CRUN and STEP=2 → 4 into the file /home/fcentoni/umui_jobs/xiepc/SUBMIT in order to allow Hector to keep up the run.

When I resubmit the job on UMUI (without processing again) I get the message:

WARNING: you have not processed the job yet.

I can choose to submit anyway and the system goes on with the extracting process but then it comes out with the message:

/home/n02/n02/fcentoni/um/umui_out/xiepc000.xiepc.d13053.t102059.comp.leave
You have selected a compilation step and continuation run CRUN.
This is not allowed. Please modify your UMUI settings. For quick fix set RCF_NEW_EXEC to false in SUBMIT file.

So I wonder, is there any permission settings I still have to set up?

Many thanks. Regards,
Federico.

comment:33 Changed 7 years ago by ros

Hi Federico,

This problem arises because you have the job set up to compile the reconfiguration. So just changing TYPE=NRUN → CRUN and STEP=2 → 4 isn't enough. As the message says; for a quick fix set RCF_NEW_EXEC to false in the SUBMIT file and it should submit the CRUN ok.

To fix it through the UMUI, you should go into the UMUI windows Compilations and Modifications → Compile Options for UM and Compile options for Reconfiguration and switch them both to Run from existing executable. Process the job and then change TYPE=NRUN → CRUN in SUBMIT

Regards,
Ros.

comment:34 Changed 7 years ago by fcentoni

Hi Ros,

I have been looking at the output files in the folder /work/um/xiepc/archive which Hector came out with running for 2 years.
Particularly, scrolling down the fields of the output fields using xconv, I have been trying to identify the diagnostics corrisponding to Ox budget: O3 dry deposition (2D) and Ox budget:NOy dry deposition (2D) and NOy wet deposition (3D).
The problem is that there is not a correspondence between the stash diagnostics I mentioned above and the diagnostics in the output files, particularly the monthy mean files (xiepca.pmj0dec and similar) which I am more interested in.
Looking at these files, I noticed that considering the fields which are named 'stach code=34001…34021…34321,322,331..', the one stash code=34321,34322 do not contain the O3 dry dep and NOy dry dep fields but others (Temp? and something else).

Can you help me out to indentify which are the correct dry deposition fields I should look at?
Many thanks. Regards,
Federico.

comment:35 Changed 7 years ago by luke

Hi Federico,

cc Ros,

The name in xconv doesn't necessarily correspond to what the field actually is - this is due to the fact that xconv doesn't know about these diagnostics, and the code which assigns the name actually corresponds to another UM code. I'm sorry about this, but the easiest thing to do is not to worry too much. The name is unimportant, what is important is the STASH code (e.g. 34321 etc) which can only correspond to the diagnostic you have requested in the UM STASH panel.

As I mentioned previously, I am in the process of making up a job with improvements to the Wesely interactive dry deposition scheme for you. This job will be based on the UKCA standard release job. I will let you know when it is ready - I'm just finishing off my compilation checks.

Thanks,

Luke

comment:36 Changed 7 years ago by luke

Hi Federico,

I have finished adding in the updates to the Wesely interactive dry-deposition scheme into the release branch for you. Please take a copy of my job xgwhi. This job is the same as the release job xfvfc, but with these code changes (and uses my branch vn7.3_UKCA_CheM_vn1.0_Wesely), the Wesely scheme turned on and a new user pre-STASHmaster file included which allows for the outputting of 3D dry deposition fields. To turn the interactive scheme off, go to

Model Selection
  -> Atmosphere
    -> Model Configuration
      -> UKCA Chemistry and Aerosols
        -> COUPL follow on window

and un-select the UKCA interactive dry deposition scheme radio button. With this scheme off, only the lowest model level of the dry-deposition diagnostics will have non-zero output.

You will need to make a few other changes to allow it to run for you:

  1. Model Selection -> User Information and Target Machine -> General Details: change the User-id, Mail-id, and Tic-code for your details.
  2. Model Selection -> FCM Configuration -> FCM Extract and Build directories and Output levels: put your username instead of mine (luke) in the Target machine root extract directory (UM_ROUTDIR).

Thanks,

Luke

Last edited 7 years ago by luke (previous) (diff)

comment:37 Changed 7 years ago by fcentoni

Dear Ros,

I have been trying to run a new release job containing all the dry deposition updates that Luke provided me but the run failed.It turns out I ran out of space on Hector. Actually, I have just archived one run so I was wondering if you can give me more.

Many thanks. Regards,
Federico.

comment:38 Changed 7 years ago by grenville

Federico

I have increased your quota to 500GB. Can you estimate what your requirements will be?

Grenville

comment:39 Changed 7 years ago by fcentoni

Hi Ros,

I have been trying to create a new branch and merge in Luke branch, as suggested by him.
I created a new trac ticket (#501) and then I launched GUI and put in the URL line the luke branch as requested.
In the line 'other options' I put —password "" as indicated in the Metoffice FCM user guide.
When I run I get the message:

"fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 fcentoni_DryDep_Wesely fcm:um_br/dev/luke/vn7.3_UKCA_CheM_vn1.0_Wesely —password """ failed (512)

Many thanks. Regards,
Federico.

comment:40 Changed 7 years ago by ros

Hi Federico,

You need to create your branch from the UM Trunk at UM7.3 first.

So in the FCM GUI you need to put:

URL → fcm:um_tr@vn7.3
Branch name → DryDep_Wesley
Related Trac Ticket → 501
Other options → —password ""

Note: there no need to put your username in the branch name as it will be created in your space in the repository

Once you have created your branch you then need to check out a working copy by running the following command.

fcm co fcm:um_br/dev/fcentoni/vn7.3_DryDep_Wesely

This will create a working copy.

Then to merge in Luke's branch run:

cd vn7.3_DryDep_Wesely
fcm merge fcm:um_br/dev/luke/vn7.3_UKCA_CheM_vn1.0_Wesely
fcm commit

You will then have luke's code in your new branch.

Regards,
Ros.

comment:41 Changed 7 years ago by fcentoni

Hi Ros,

I created a branch as you suggested above using GUI.
Then when I run the command fcm co fcm:um_br/dev/fcentoni/v7.3_DryDep_Wesley

I get the message:
fcentoni@puma:/home/fcentoni> fcm co fcm:um_br/dev/fcentoni/v7.3_DryDep_Wesely
svn: URL 'svn://puma/UM_svn/UM/branches/dev/fcentoni/v7.3_DryDep_Wesely' doesn't exist
[FAIL] svn checkout svn://puma/UM_svn/UM/branches/dev/fcentoni/v7.3_DryDep_Wesely # rc=1

I tried changhing v7.3_DryDep_Wesely with tha name of the branch choosed by you (DryDep_Wesely) but I get the same error message.

Many thanks.
Federico

comment:42 Changed 7 years ago by fcentoni

Hi Ros,

I don't if you got my previous enquiry but I am still trying to create a new branch. Once I put in GUI lines what you suggested to, I get the message:

# Start: 2013-03-08 12:28:52⇒ fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely fcm:um_tr@vn7.3 —password ""
[info] Source: svn://puma/UM_svn/UM/trunk@1678 (1678)
[info] gedit: starting commit message editor…
Can't exec "gedit": No such file or directory at /home/um/fcm/bin/../lib/FCM/System/CM/CommitMessage.pm line 91.
[FAIL] gedit /tmp/sw2tUIi4OH # rc=-1

"fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely fcm:um_tr@vn7.3 —password """ failed (512)
# Time taken: 2 s⇒ fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely fcm:um_tr@vn7.3 —password ""

Then, if I run the command fcm co:um_br/dev/fcentoni/v7.3_DryDep_Wesely, I get :

fcentoni@puma:/home/fcentoni> fcm co fcm:um_br/dev/fcentoni/v7.3_DryDep_Wesely
svn: URL 'svn://puma/UM_svn/UM/branches/dev/fcentoni/v7.3_DryDep_Wesely' doesn't exist
[FAIL] svn checkout svn://puma/UM_svn/UM/branches/dev/fcentoni/v7.3_DryDep_Wesely # rc=1

Probably, there is something wrong with the URL.
Thank you. Cheers,
Federico.

comment:43 Changed 7 years ago by ros

Hi Federico,

Hmmmm strange, for some reason I didn't get your previous message.

The branch creation is failing because you haven't got your editor environment variable set up.

You need to add one of the following lines to your $HOME/.profile or $HOME/.kshrc file on PUMA.

# Emacs
export SVN_EDITOR=emacs

# NEdit
export SVN_EDITOR='nedit'

# vi
export SVN_EDITOR='xterm -e vi' 

If you haven't already done so please work through the FCM UM Tutorial before using FCM in anger as this takes you through all the setup and basic branch creation and usage of FCM for the UM.

Regards,
Ros.

comment:44 Changed 7 years ago by fcentoni

Hi Ros,

I am still trying to create a new branch but I don't manage. I followed all the instructions (including all the settings mentioned in the tutorial).

Again, creating a new branch with GUI, I put:

URL: um_br@vn7.3
Branch Name: DryDep_Wesely
Ticket:501
Other Options:—password""

I run and I get the message:

# Start: 2013-03-12 14:59:45⇒ fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely um_br@vn7.3 —password ""
[FAIL] svn info —xml um_br@vn7.3 # rc=1

"fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely um_br@vn7.3 —password """ failed (256)
# Time taken: 0 s⇒ fcm branch-create —svn-non-interactive -t DEV —rev-flag NORMAL -k 501 DryDep_Wesely um_br@vn7.3 —password ""

Once I have done it, if I try to run the command fcm co fcm:um_br/dev/fcentoni/DryDep_Wesely, I get the message:

fcentoni@puma:/home/fcentoni> fcm co fcm:um_br/dev/fcentoni/vn7.3_DryDep_Wesely
svn: URL 'svn://puma/UM_svn/UM/branches/dev/fcentoni/vn7.3_DryDep_Wesely' doesn't exist
[FAIL] svn checkout svn://puma/UM_svn/UM/branches/dev/fcentoni/vn7.3_DryDep_Wesely # rc=1

I am sorry but I don't know how to cope with that.
Many thanks. Regards,
Federico.

comment:45 Changed 7 years ago by ros

Hi Federico,

The URL should be fcm:um_tr@vn7.3 not um_br@vn7.3

Alternatively, just run on the command line:

fcm branch-create -k 501 DryDep_Wesely fcm:um_tr@vn7.3

You will be prompted for a password; simply press return

Regards,
Ros.

comment:46 Changed 7 years ago by fcentoni

Thanks Ros,

It worked. Once I created a new branch, now I have to merge mine with Luke's.
So I have to follow your previous instructions:

cd vn7.3_DryDep_Wesely ← How do I manage to get to this folder?
fcm merge fcm:um_br/dev/…
fcm commit

Thanks again.
Federico

comment:47 Changed 7 years ago by ros

Hi Federico,

See my response in comment:40

You need to check out your branch to get a working copy before you can edit it.

fcm co fcm:um_br/dev/fcentoni/vn7.3_DryDep_Wesely

Regards,
Ros.

comment:48 Changed 7 years ago by fcentoni

Hi Ros,

I have been trying to run a job which I had already run but killing it on Hector after 5 years of run lenght. So I was wondering,if I may run the same job xiepa running it from Jun 1995 (instead of Sep 1990 as previously set up)until Dec 2000. I tried to do that changing the run lenght on UMUI but the run failed. Looking at the file xiepa000.xiepa.d13085.t153859.leave I found the error:

UM ERROR (Model aborting) :

Routine generating error: INITIAL
Error code: 1
Error message:

INITTIME: Atmosphere basis time mismatch

Many thanks. Regards,
Federico.

comment:49 Changed 7 years ago by ros

This ticket is now being closed as original query has been solved.

comment:48 has been raised as a new ticket #1043

comment:50 Changed 7 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.