Opened 6 years ago

Closed 6 years ago

#1025 closed help (fixed)

Problem with UM submission

Reported by: pclark Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: MONSooN
UM Version: 8.1

Description

Hi

I'm new to MONSooN. I've managed to build a UM exec, but a reconfigure and run job (copied from carol Halliwell, running on main met office system) xieza, fails at the first hurdle with:

*

Version 8.1 template, Unified Model , Non-Operational
Created by UMUI version 8.1

*
Host is c02c07n06-hf0
Creating directory /scratch/paclar/xieza
Creating directory /projects/dymecs/paclar/xieza
PATH used = /critical/opt/ukmo/mass/moose-monsoon-batch-node-client/bin/ibm-cn:/usr/bin:/etc:/usr/sbin:/usr/bin/X11:/sbin:/usr/java5/jre/bin:/usr/java5/bin:/critical/opt/ukmo/supported/bin:/critical/opt/ukmo/freeware/bin:/opt/freeware/bin:/projects/um1/vn8.1/ibm/utils:/projects/um1/vn8.1/ibm/utils:/projects/dymecs/paclar/xieza/bin:/projects/um1/vn8.1/ibm/scripts:/projects/um1/vn8.1/ibm/exec
/home/paclar/umui_runs/xieza-045182428/umuisubmit_rcf[332]: UMScr_TopLevel: not found

/critical/opt/loadl/bin/eoj ( (131223:177340:33261:1:0:0:0:47912:1360866284:1329923416:1343221820:16777216:1024))

etc…

I'm guessing the 'UMScr_TopLevel: not found' is the critical problem, but I cannot see what's wrong with my job. Any help gratefully received.

Change History (9)

comment:1 Changed 6 years ago by willie

Hi Peter,

It seems that you are feeding a UM7.8 executable with a 8.1 UMUI setup - I've not tried this myself, but feel that it could cause problems.

Other issues are,

  • you need to make all your hand edits executable - chmod +x
  • in FCM options - untick "Use different …"
  • In Control > Post Proc > User scripts, switch off
  • The check set up is complaining that you are running with Gravity wave drag off

I hope that helps.

Regards,

Willie

comment:2 Changed 6 years ago by ros

Hi Pete,

The problem is because you're running using an executable from a different job and I haven't manually copied all the UM scripts into the central directory to cater for this case. :-( The job scripts, by default, only get extracted during a compile.

I will place a copy of the scripts centrally in due course but in the meantime if you go to the UMUI window Compilation and Run Options → UM Scripts Build and switch on Enable build of UM scripts this will extract you a copy of all the UM scripts.

Regards,
Ros.

Last edited 6 years ago by ros (previous) (diff)

comment:3 Changed 6 years ago by pclark

Thanks to all. I will action!

A few comments:

  • I worried myself about the version discrepancy but I'm picking up jobs from colleagues which allegedly work, mainly as a starting point. As yet, we I haven't got as far as running the exec!
  • All my used in the job handedits are executable by me, as far as I'm aware.
  • I don't understand the 'use different' button under FCM options - on Hector, I found I had to tick this or jobs didn't work. It seems sensible that it isn't.
  • Most people I work with build executables with one job and run them with another - it's terribly inefficient to recompile every time you run a job!
  • I don't understand the GWD complaint - running without GWD is standard practice at high resolution (or should be).

comment:4 Changed 6 years ago by ros

Hi Pete,

Just to answer one of comments:

The "use different" button under FCM options has to be set to vnx.y_cfg for earlier versions of the UM under FCM in order to pick up the correct configuration files for HECToR. This was a workaround for an FCM problem in the early days. At later versions (7.5+), "use different" can be left unselected and the vnx.y_cfg keyword must be appended to the "UM Container Filename" setting in the same window (E.g. $UM_SVN_BIND/container.cfg@vn8.2_cfg)

Cheers,
Ros.

comment:5 Changed 6 years ago by pclark

This now fails at the extraction - using"UM Container Filename" setting $UM_SVN_BIND/container.cfg@vn8.1_cfg fails with:

[FAIL] svn://fcm2/UM_svn/UM/trunk/src/configs/bindings/container.cfg@vn8.1_cfg: revision keyword not defined

comment:6 Changed 6 years ago by pclark

I've realised my base repository wasn't correct (job copied from Met Office) - however, I still get the same failure after correction:

[FAIL] svn://puma/UM_svn/UM/trunk/src/configs/bindings/container.cfg@vn8.1_cfg: revision keyword not defined

comment:7 Changed 6 years ago by pclark

Losing the @vn8.1_cfg does seem to work, at least as far as submission.

comment:8 Changed 6 years ago by ros

Hi Peter,

You only need the vnx.y_cfg in order to run on HECToR. For MONSooN you can leave the UM Container setting as is. Most times it will work on MONSooN with the vnx.y_cfg keyword set, but we don't have UM8.1 installed on HECToR so that's why it's failing at this version.

Cheers,
Ros.

comment:9 Changed 6 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.