Opened 6 years ago

Closed 6 years ago

#1035 closed help (fixed)

xancil - error

Reported by: df019697 Owned by: jeff
Component: UM Model Keywords: xancil
Cc: Platform: HECToR
UM Version: 6.1

Description

I'm currently trying to run my own experiment using ancillary files generated with xancil (SST and sea ice).

The experiment is xigtc.
/work/n02/n02/df019697/xigtc

The leave file in /home/n02/n02/df019697/um/umui_out/xigtc000.xigtc.d13066.t165000.comp.leave

gives an error:

UM ERROR (Model aborting) :
Routine generating error: INITIAL
Error code: 8
Error message:

INANCILA: REAL header Error.

Cheers,
Ray

Change History (5)

comment:1 Changed 6 years ago by df019697

the title should be 'xancil - error!'

I have had another crack at this now. I've updated the start dump to start at the same time as the ancillary files. I was also using 5-daily sea ice data and now am using monthly means, the same as the SST.

Unfortunately I am still getting the error as above and running low on ideas for where to look for the error.

Cheers,
Ray

comment:2 Changed 6 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted
  • Summary changed from xancil - errpr to xancil - error

Hi Ray

This error is probably because of a mismatch in the real header values between the start dump and your ancillary files caused by using 32 bit real values. If you recreate the netcdf files as 64 bit files then hopefully this problem will go away.

If you use convsh to create the netcdf files add this line before you read the files

set ncprec 64

Jeff.

comment:3 Changed 6 years ago by df019697

Hi Jeff,

I created the netcdf files in IDL, see /home/df019697/PhD/IDL/model_exps/HiGEM_nutSST_comp.pro

I had a play around with xancil→configuration→general configuration→ancillary file data size: 32 bit or 64 bit but got the same error as above.
I did also play with 'use of 32 bit data packing' and got an error:

UM ERROR (Model aborting) :

Routine generating error: INITIAL
Error code: 14
Error message:

INANCILA: Insufficient space for LOOKUP headers

Cheers,
Ray

comment:4 Changed 6 years ago by jeff

Hi Ray

The problem comes from using 32 bit values on the Netcdf side, so changing the UM format won't affect that. Its the Netcdf files which need to be 64 bit. If changing the Netcdf files is too difficult an alternative is to just disable the piece of code which forces the exit. You can write a mod which deletes this line INANCA1A.493 in deck INANCA1A and the code will just continue. In general this is a bad idea because there could be real errors you would be hiding but in this case I think it is a false error.

Jeff.

comment:5 Changed 6 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.