Opened 6 years ago

Closed 6 years ago

#1042 closed help (fixed)

fcm conflict - skipped unhandled tree conflict

Reported by: luke Owned by: ros
Component: FCM Keywords: merge, conflict
Cc: Platform: PUMA
UM Version: 7.3

Description

I'm trying to merge in two branches, both of which are based on the same original branch, and were copied by doing a fcm merge rather than a branch-of-branch. I believe that I have merged all the code in correctly, but am having the following error:

[12:45:55 luke@puma src]$ fcm commit
/home/luke/FCM/VN7.3/vn7.3_UKCA_CheM_vn1.1.1: working directory changed to top of working copy.
[ERROR] File(s) in conflicts:
      C      11386   src/utility/netcdf_utils
[FAIL] Fcm::Cm::Abort: abort

Exit 255

When I run fcm conflicts I get the following message

[12:44:27 luke@puma netcdf_utils]$ fcm conflicts
[WARN] src/utility/netcdf_utils: skipped unhandled tree conflict.

How can I resolve the conflict and commit these changes. I'm not actually sure there are any changes in the src/utility/netcdf_utils directory either.

Thanks,

Luke

Change History (6)

comment:1 Changed 6 years ago by ros

Hi Luke,

Hmmmmmm…. interesting…. not seen that error before.

Which branch are you trying to merge into vn7.3_UKCA_CheM_vn1.1.1 - Is it fcm:um_br/dev/ptelford/VN7.3_UKCA_CheM_vn1.1_StratCFC_Solar?

Think I'm going to have to try this one out myself to figure out what's going on.

Cheers,
Ros.

comment:2 Changed 6 years ago by luke

Hi Ros,

My branch is vn7.3_UKCA_CheM_vn1.1.1, and I was trying to merge Paul's VN7.3_UKCA_CheM_vn1.1_StratCFC_Solar branch into it.

Thanks for taking a look at this!!

All the best,

Luke

comment:3 Changed 6 years ago by luke

I should also point out that there were a lot of conflicts in the merge - ~40 files.

comment:4 Changed 6 years ago by ros

Hi Luke,

FCM appears to have issues when the same directory has been added to 2 branches. I got the same problem merging two branches that both just had the same directory added. You have added src/utility/netcdf_utils to your branch and Paul has too. Assuming that you have both added exactly the same files then running the following command in your working copy should get around this problem.

svn resolve --accept working src/utility/netcdf_utils

Apparently, tree conflicts are a new addition to subversion and have caused some annoyances.

Regards,
Ros.

comment:5 Changed 6 years ago by luke

Hi Ros,

That's got it - thanks! I've been able to fcm commit.

I'm not quite sure what a 'tree conflict' is, but I can see that they can be quite annoying!

I've had lots of issues with the conflicts command, mainly because the code it's checking against is so different from the UM trunk. The xxdiff window which opens is always very busy and it's difficult to actually work out what the conflicts are. I've written a bash script which helps, which automatically diffs the working and merge-right (i.e. the branch coming in) versions (the merge-left is the trunk):

[14:49:48 luke@puma ~]$ less ~/bin/.scripts/cdiff.bash
#!/bin/bash

# compares the two important files created when a conflict arises with FCM

ifile=`echo ${1} | awk -F\: '{print $1}'`

echo $ifile

/usr/local/bin/xxdiff -wbiB -A" --minimal" ${ifile}.working ${ifile}.merge-right.r*

I run this on the file which fcm conflicts it considering at the time. This gives the proper list of differences. However, any advice as to how to do this better would be appreciated!

Many thanks,

Luke

comment:6 Changed 6 years ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.