Opened 6 years ago

Closed 5 years ago

#1071 closed help (completed)

UKCA O3-NOy daily output run failed

Reported by: fcentoni Owned by: luke
Component: UM Model Keywords:
Cc: Platform: HECToR
UM Version: 7.3

Description

Dear Ros (cc Luke),

I tried to run UKCA with O3/NOy daily outputs but the continuation run failed (it turned off all the emission diagnostics which do not work and the LAI diagnostic as well). Actually,Hector compiled the new run without any trouble.

The output file is xiepd000.xiepd.d13139.t172954.leave. Can you help me out to interpret the errors the model came out with?

Many thanks. Regards,
Federico.

Change History (7)

comment:1 Changed 6 years ago by luke

  • Owner changed from um_support to luke
  • Status changed from new to accepted

Hi Federico,

The error that you are getting here is

 Error in STASHSTWORK   : NO. OF FIELDS EXCEEDS RESERVED HEADERS

which is an error from STASH saying that you are requesting too much output to go to one of the output streams. Looking in your job, this is because you are sending 7200 fields to stream 69 (in the STASH window go to Diagnostics -> Verify Diagnostics to see warning messages). This is the UPJ stream, which you have a 30-day repeat on (go to Model Selection -> Post processing -> Initialization and processing of mean and standard PP files to see where this is set).

Since the time usage on these streams is daily, I would suggest changing the repeat to 1 day in the file panel. I would also suggest changing the end point of the diagnostics to -1 from 10800 (i.e. 30 years). I don't think at the moment that you plan to run for more than 30 years, but if you did these diagnostics would not be output anymore.

Making this change seems to remove the warning. You will need to run the job with it in to see if any other errors occur. Since the job ran for 18 days before crashing then it is likely. You may even be able to change the repeat to 15 days, which would reduce the amount of files (but not the space used).

Thanks,

Luke

comment:2 Changed 6 years ago by fcentoni

Dear Ros (cc Luke),

The run is still failing.
I consistently reduced the amount of fields sent to the stream 69 excluding from the output many diagnostics I don't need the model to come out with.
It seems there are not warning message anymore if you verify the diagnostics (it says: "Number of diagnostics:444 of which 24 are switched on: No errors"

In the output file xiepd000.xiepd.d13142.t110603.leave I still found the message:

{{ Routine generating error: UKCA_MAIN1

Error code: 34
Error message:
Error in STASHSTWORK : NO. OF FIELDS EXCEEDS RESERVED HEADERS

}}

Many thanks,
Federico.

comment:3 Changed 6 years ago by luke

Hi Federico,

I still think that the error is that you have too many fields going to this stream, even taking into account the changes that you have made. If you sort the STASH output by stream it is failing at 34,321, which is the third to last output made to UPJ, and the .leave file states that there are 4097 fields in that stream. You only have 34,322 and 34,331 left to go in. I suggest using the PI (or another PP stream you are not currently using) and send some of the data there, also making it a daily file in the post-processing window as you did for PJ. I'm not sure why STASH thinks the output is OK when the model doesn't.

I also notice that to remove some warnings you have turned off output of some of the UKCA tracers that were going to UPMEAN. There is no need to do this, since these tracers will be output, despite what STASH says here.

If you get the error

DIAGNOSTIC    ERROR: Diagnostic is not available for this model configuration.

this means that STASH thinks that it cannot be outputted because the tracer is turned off. In fact, tracers which give these errors will be output since they are turned on when the PROCESS button is pressed (which the STASH panel will not know about). I strongly advise you to turn these tracers back on.

I'm sorry for this bug - it will be addressed in a later version of the UM.

Thanks,

Luke

comment:4 Changed 6 years ago by fcentoni

Dear Ros (cc Luke),

I finally got the model running yesterday but it seems that it was not coming out with the right output fields so that I stopped the simulation after one day.
In the daily files you can just find the soil moisture field and there is not sign of O3,NOy dry dep at all.
I guess there is something wrong about the daily time domain the model is not happy with.

Many thanks. Cheers,
Federico.

comment:5 Changed 6 years ago by fcentoni

`Dear Ros (cc Luke),

I don't know if you got my previous comment but I am still trying to get the model properly running with daily output. It turned out the model didn't produce anything but a few fields I am not interested in.

Once you helped me out to fix up the trouble, I would like to output these diagnostics, in order to investigate the relative contribution from each resistance to the ozone dry deposition:

Sec. 3 item 54 Aerodinamic resistance
Sec. 3 item 63 Quasi-laminar resistance
Sec. 3 item 259 Canopy conductance
Sec. 3 item 462 Stomatal conductance on PFTS
Sec. 3 item 465 Friction velocity

Particularly, I'd like to know if these diagnostics are working and may be outputted on a daily basis (for the stomatal conductance I chosed the domain DPFTS).
Is the quasi-laminar resistance actually active with the configuration I run with?
The help it says (for S cycle).
I verified the diagnostics and it seems there is not any warning message relative to these diagnostics.

Many thanks. Regards,
Federico.

comment:6 Changed 6 years ago by luke

Hi Federico,

As the files are written on the fly, the data may not show up when read in xconv until it has been closed and a new file has been opened, so I suggest running the job for at least 2 days before determining if the data has been output or not.

As for the diagnostics above, I'm not sure if they can be output or not - the best thing to do is to try to output them and see if they appear. It may be that these are only on if the land-surface scheme is on, rather than running from an ancillary as this job is doing. If this is the case you would need to write additional diagnostics in the UKCA diagnostics package (asad_chem_flux_diags.F90 and associated asad_flux_dat.F90) to output what UKCA sees as these quantities during run-time.

Thanks,

Luke

comment:7 Changed 5 years ago by luke

  • Resolution set to completed
  • Status changed from accepted to closed

Hi Federico,

As there hasn't been any activity on this ticket for a few months, I'm going to close it. Please open a new ticket if you still have problems.

Thanks,
Luke

Note: See TracTickets for help on using tickets.