Opened 7 years ago

Closed 7 years ago

#1077 closed help (fixed)

Submitting to monsoon using UMUI: ": is not an identifier"

Reported by: ledm Owned by: um_support
Component: MONSooN Keywords: UMUI, MonSOON
Cc: Platform: MONSooN
UM Version: <select version>

Description

Hi,

for about a day now, I've been unable to submit jobs to monsoon using the UMUI. The standard output file only contains the words:

: is not an identifier

followed by the usual monsoon information:

/critical/opt/loadl/bin/eoj ( (131223:177340:33261:1:0:0:0:47912:1370425542:1329923416:1343221820:16777216:1024))

Run at Wed Jun 05 09:45:42 GMT 2013 on c02c12n02-hf0 for jobstep mon002.64664.0
Queued           : Wed Jun  5 09:45:41 2013 for       1 seconds
Dispatched       : Wed Jun  5 09:45:42 2013 for       1 seconds
Exit Code        : 256
Job Name         : xhonl_build
Step Name        : 0
Owner            : ldmora
Notify User      : ldmora@l000
Unix Group       : users
Account          : imarnet
STDIN            : /dev/null
STDOUT           : /home/ldmora/output/xhonl000.xhonl.d13156.t094446.comp.leave
STDERR           : /home/ldmora/output/xhonl000.xhonl.d13156.t094446.comp.leave
Class            : serial
Step Type        : Serial
Node Usage       : shared
Step Cpus        : 4
Total Tasks      :
Blocking         :
Adapter Req.     :
Resources        : ConsumableVirtualMemory(3.000 gb) ConsumableCpus(4) ConsumableMemory(3.000 gb)
Comment          :
#*#* Next 3 times NOT up-to-date (TOTAL CPU TIME given later IS accurate)
Step User   Time : 00:00:00.000000
Step System Time : 00:00:00.000000
Step Total  Time : 00:00:00.000000 (0 secs)
#*#* Last 3 times NOT up-to-date (TOTAL CPU TIME given later IS accurate)
Context switches : involuntary =            0, voluntary   =            0
                    per second =            0                           0
Page faults      : with I/O    =            0, without I/O =            0
                    per second =            0                           0

------------------<----------- CPU ------------->-<------------ MEMORY ---------------->------------
            t  t |     total   average   current |   total   current   maximum    ratio |
            a  h |  physical  consumed  consumed | alloc'd  consumed  consumed  maximum |
            s  r |       CPU  physCpu/  physCpu/ |  memory    memory    memory  memory/ |
            k  d |   seconds   alloc'd   alloc'd | on node   on node   on node  alloc'd |
Node     ?  s  s |  consumed  SMT-thrd  SMT-thrd |    [MB]  /alloc'd      [MB]   memory | task list
-----------------|-------------------------------|--------------------------------------|-----------
 * below denotes that this step allowed SMT: CPU efficiency may depend on coallocated foreign steps
-----------------|-------------------------------|--------------------------------------|-----------
----------------------------------------------------------------------------------------------------
        Elapsed:        1.00 sec                   Alloc'd memory/task:   3072 MB
        CPU Tot:        0.00 sec ( 0+00:00:00)     Average: 0 s/node, 0 s/task

System Billing Units used by this jobstep = 0.011

I recently changed by .kshrc and .bashrc files on monsoon, but I can't see anything there that would break job submission.

Thanks for your help,

Lee

Change History (6)

comment:1 Changed 7 years ago by willie

Hi Lee,

I copied your job and the compile started OK, so that suggests the problem is with your .kshrc and .bashrc files on MONSooN. I couldn't find the .kshrc. Your .bashrc file contains a lot of aliases and it is possible that these could interfere with the UM scripts.

Regards,

Willie

comment:2 Changed 7 years ago by ledm

Hi,

I don't think the problem is due to bashrc, as this code has been relatively stable in the past.

However, I tried to set my default shell to bash using a few methods, none of which were successful. Does the UMUI require a specific default shell?

I think I ran some command like:
chsh -s /bin/bash ldmora

When I log into ibm02, I get the following error:

-bsh: [[: not found
-bsh: ENVIRONMENT=INTERACTIVE: is not an identifier

Is there some way to undo this and reset it to the default?

Thanks

comment:3 Changed 7 years ago by ledm

it looks like a solution was to run the command:
chsh <username> /bin/ksh

comment:4 Changed 7 years ago by willie

Hi lee,

Yes, the UM expects ksh. Is your job running now?

Regards

Willie

comment:5 Changed 7 years ago by ledm

Hi,

yes, the job is running now. Thanks,

Lee

comment:6 Changed 7 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.