Opened 7 years ago

Closed 7 years ago

#1085 closed help (fixed)

UM Reconfiguration Problems

Reported by: RPope Owned by: willie
Component: UM Model Keywords:
Cc: nicholas.savage@… Platform: MONSooN
UM Version: 8.2

Description

Hi All,

I have been having some problems with reconfiguration (RCF) of a UM job xiosb. Essentially I am trying to run a simulation for JJA 2008 using a regional version of the UM/UKCA. Now the model compiles successfully, but when I do the RCF it finds the start dump for 16/05/2008 at 12.00 (2 weeks for spin up) and not the LBCs file. For notice, this job uses v.n 8.2 and is run off of MONSOON.

The LBCs are stored in a directory called /projects/ukca/nsavag/lbc_archive/siejn, but the model thinks they are in /projects/ukca/nsavag/lbc_archive. The error file is attached above. I have gone onto the LBCs window in the UMUI for the job and the directory and file paths for the LBCs are set as $AQUM_DATA and $LBCFILE, respectively. Now in the error message is says it can't find

"/projects/ukca/nsavag/lbc_archive/200805161200qm.alabcou1", so it looks like $LBCFILE is working because it creates the correct file string. However, "/projects/ukca/nsavag/lbc_archive/" is incorrect. So, I go to I/P options and then select Time and Script Env Variables (or some thing like that) and I have changed

$AQUM_DATA =/projects/ukca/nsavag/lbc_archive/ to $AQUM_DATA =/projects/ukca/nsavag/lbc_archive/siejn.

Now I think it should be looking in the correct directory, but I have tried rerunning the compile and RCF in xiosb are it doesn't update $AQUM_DATA and cannot find the files. It seems that no other components of the UMUI use $AQUM_DATA, so I deleted it and renamed it
$AQUM_DATA2 with the new path /projects/ukca/nsavag/lbc_archive/siejn. Then recompiled and RCF the model, to which it spat out the same error message. I have also hard coding the correct directory path in but it doesn't like it either. Does anyone have any idea/experiences where you change one of the Environment Variable in the UMUI and it ignores it and uses a previous pathway?

Just to say I also tried setting up the job again called xiosc to see if xiosb was corrupted, but it shows the same errors. I have also checked and there are no hand edits either in use to over write the variable AQUM_DATA.

Cheers,

Richard Pope

Attachments (1)

xiosc000.xiosc.d13169.t125631.rcf.leave (3.6 KB) - added by RPope 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by RPope

comment:1 Changed 7 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Richard,

The LBC files in your job are indicated by the environment variables AQUM_DATA and LBCFILE. The former is set on the Time Conventions and SCRIPT environment variables page. The latter is set in the top script on the Script inserts and modifications page. You need to modify these to point to your LBC file. The use of a top script to do this may be unnecessary.

Regards,

Willie

comment:2 Changed 7 years ago by grenville

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.