Opened 6 years ago

Closed 5 years ago

#1091 closed help (completed)

problems using sea ice and sst ancillaries

Reported by: cwright Owned by: jeff
Component: UM Model Keywords: SST, sea ice, ancillaries
Cc: Platform: HECToR
UM Version: 6.6.3

Description

Hi,

I'm trying to use some SST and sea ice ancillaries to drive the surface forcings of the UM, but I can't seem to get then working. We need them to provide realistic surface forcing for a run nudged in the stratosphere towards satellite data, which the standard climatological SSTs and sea ice won't be accurate enough for as it's only over a few months.

My job is xibio; xibil is the same job (maybe plus or minus some small divergences from my attempts to get xibio working) with the standard UM ancillaries and works fine.

The job xibio also does some nudging using HIRDLS data, which may have been confusing things, so I've also tried running it without the nudging as xibim and xibip (normal/modified ancillaries respectively), so I'm fairly sure the problem is here.

My ancillaries are on Hector in ~cwright/ancil (specifically, ice.anc and sst.anc), and seem to open fine in xconv (they were produced with xancil from a netCDF dataset supplied by a colleague). However, I get the following error message when I try to run them:

*
UM ERROR (Model aborting) :
Routine generating error: INITIAL
Error code: 4
Error message:

PR_FIXHD: Consistency check

*

and I'm not quite sure how to fix it. I've tried, on the suggestion of colleagues, changing to configured, running reconfiguration-only, and then running again; this didn't help. Any advice you had would be much appreciated :-)

I attach my .leave file, as it's pretty small since it fails so early.

Thanks!

Corwin Wright

Change History (9)

comment:1 Changed 6 years ago by cwright

Actually, I haven't attached the .leave file - it was bigger than I thought! It's on Hector as:

~cwright/um/umui_out/xibio000.xibio.d13178.t143450.leave

comment:2 Changed 6 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Corwin

The problem is your ancillary file is in little endian format but the UM expects the file to be in big endian format. I see in your directory you already have files in big endian format so give those a try instead.

Jeff.

comment:3 Changed 6 years ago by cwright

Hi Jeff,

I'd already tried a big-endian format, but that segfaulted, so I assumed it was wrong! I've tried rerunning it today just in case another change I'd made had fixed it, but it's still happening:

_pmiu_daemon(SIGCHLD): [NID 02638] [c3-0c0s7n2] [Mon Jul 1 14:23:09 2013] PE RANK 64 exit signal Segmentation fault
_pmiu_daemon(SIGCHLD): [NID 02673] [c3-0c0s7n1] [Mon Jul 1 14:23:09 2013] PE RANK 32 exit signal Segmentation fault
_pmiu_daemon(SIGCHLD): [NID 02636] [c3-0c0s6n2] [Mon Jul 1 14:23:09 2013] PE RANK 112 exit signal Segmentation fault

(above from xibio000.xibio.d13182.t131923.leave, lines 42-44)

Corwin

comment:4 Changed 6 years ago by jeff

Hi Corwin

It looks like your sst/ice ancil files are causing the model to crash. Can you put the input NetCDF files and the xancil job you used, somewhere on Hector.

Jeff.

comment:5 Changed 6 years ago by cwright

Hi Jeff,

the colleague who helped me with that is on holiday this week, and I'm not sure where in his Hector space they're stored! I'm out myself on Monday, but I'll get the relevant files to you on Tuesday.

Corwin

comment:6 Changed 6 years ago by cwright

Hi Jeff,

the files should be in /home/n02/n02/lfsmo/work/ANCIL. Specifically:

HadGEM2_OSICE_OSTIA.job
OSTIA_2003_12_2008_12_HadGEM_64bit.nc
OSICE_2003_12_2008_12_HadGEM_64bit.nc

Corwin

comment:7 Changed 6 years ago by jeff

Hi Corwin

It looks like there is a problem with the land-sea mask you have imposed on your sst/ice fields. If you look at the land fraction field, you can see the land-sea mask you have used is sea = 0, land > 0, i.e. any fractional values are treated as land. But for sst and sea-ice you need to use a mask where any fractional values are sea, i.e. land = 1, sea < 1. At the moment the model is trying to use some missing data values as sst or ice values, at least this is what I think is happening. Most UM sst/ice ancillary files have the sea values extrapolated over land so they can work with different land fraction fields.

Jeff.

comment:8 Changed 6 years ago by cwright

Hi Jeff,

we've replaced the ancils with ones which are interpolated over land, but it's still segfaulting. The current ancils are:

~cwright/ancil

and are called ice.anc and sst.anc (these are renamed copies of some files in ~lfsmo/work/ANCIL, in case the filename being too long caused problems). The output is

~cwright/um/umui_out/xibio000.xibio.d13203.t181103.leave

Any ideas?

Corwin

comment:9 Changed 5 years ago by jeff

  • Resolution set to completed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.