Opened 8 years ago

Closed 8 years ago

#1094 closed help (fixed)

HadGEM-AO ocean start dump

Reported by: earjcti Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: HECToR
UM Version: <select version>

Description

Hello,
I am trying to run HadGEM-AO on Polaris (and Hector) I have used the example job and the model seems to be working. However, I have had a look at the standard ocean start dump (hadgom_216_r5_v6.8_dumpn5) and the grid looks a little strange. The latitudes range from -90-+125.
I understand this will probably be correct - as the model is running. However it would be useful if you could point me in the direction of some more information about the ocean start dump and why the grid does not go from -90-+90. I am going to try and make some changes to the ocean start dump and so any information you could provide would be helpful.
Thanks
Julia

Change History (2)

comment:1 Changed 8 years ago by grenville

Julia

This happens because the grid isn't regular - it's resolution increases towards the equator. In order to plot this properly, extra data needs to be output. Start dumps don't have the extra data. If you check an ocean field in a stash output file, you will see the correct behaviour. I'm trying to find out the gory details of how this works.

Grenville

comment:2 Changed 8 years ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed

Hi,

Tim's paper on HadGEM1 (http://journals.ametsoc.org/doi/full/10.1175/JCLI3712.1) has info for HadGOM:

The oceanic component of HadGEM1 (HadGOM1) uses a latitude?longitude grid with a zonal resolution of 1¡Æ everywhere and meridional resolution of 1¡Æ between the poles and 30¡Æ latitude, from which it increases smoothly to ¨÷¡Æ at the equator, giving 360 ¡¿ 216 grid points in total.

(and further down:)

The higher horizontal and vertical resolution, land?sea mask, and bathymetry as previously mentioned. The increased horizontal resolution and stretched grid toward the equator, in conjunction with the new coupling scheme mentioned later, allow features to be captured well beyond the capability of HadCM3. For example, observations show that most of the Indonesian Throughflow passes through Makassar Strait (Gordon and Fine 1996). In HadCM3 this strait is blocked (Banks 2000), whereas the enhanced resolution of HadGEM1 allows the bathymetry and currents in this region to be represented in more detail (Fig. 1).

There may be more info in the references from this paper on how the grid was decided, although my recollection is that Malcolm's HadCEM (Roberts et al. 2004) had something to do with it.

Hope that helps.

Gill


From: Jones, Chris D
Sent: 09 July 2013 15:32
To: Hill, Richard; 'Grenville Lister'; Johns, Tim; Martin, Gill
Subject: RE: HadGEM2 ES

Hi Richard, Grenville,

Tricky one - I suspect there might be some citation tracking work to be done to get back to this. There are a couple of HadGEM2 documentation papers:
http://www.geosci-model-dev.net/4/723/2011/gmd-4-723-2011.html
http://www.geosci-model-dev.net/4/1051/2011/gmd-4-1051-2011.html

But I doubt they have this level of detail. The first of those is your best bet here - I just flicked through and there's a figure on vertical resolution, but couldn't spot much on the horizontal grid. The ocean model dates back to HadGEM1, so Tim Johns and/or Gill Martin (now cc'd) might have a long enough memory to be able to answer? (Gill's HadGEM2 paper above cites both Johns et al and Martin et al papers on HadGEM1). I think the hands-on experience of what is now our old ocean GCM is a bit of a dying bread.

Cheers,
Chris


Mr Chris Jones
Head, Earth System and Mitigation Science Team Met Office Hadley Centre, FitzRoy? Road, Exeter, EX1 3PB, U.K.
Tel: +44 (0)1392 884514 Fax: +44 (0)1392 885681
E-mail: chris.d.jones@…<mailto:chris.d.jones@…> http://www.metoffice.gov.uk


From: Hill, Richard
Sent: Tuesday, July 09, 2013 12:44 PM
To: 'Grenville Lister'
Cc: Jones, Chris D
Subject: RE: HadGEM2 ES

Hi Grenville,

I can't find anything which describes the HadGEM2 ocean

grid set up as such, or how the grid spacings

were decided on so I'm copying to Chris as he might know

of something suitable or of someone who knows

something suitable.

If the issue is to do with the definitions of the variable

horizontal grid spacings, then

a suitably old version of UMDP F3 might help. I've

attached an old F3 copy from UM vn6.3.

The key to figuring out the latitude spacings is what's in

the "Row Dependent Constants"

If you use the "pumf" tool to see what's in an ocean dump

header, then you'll see the latitude grid spacings

start with 1.0, but gradually get smaller towards the

equator. (These are the T points, the U and V points

are derived from these in the model.)

The "BDY" (Y direction spacing) value in the field headers

is obviously irrelevant under these circumstances

(and the UMDP states that for variable grid spacings BDY

would have a value of zero

but I'm sure there were plenty of instances where it still

had a value of 1.0 or whatever

which was just ignored.)

Diagnostic (pp) files carried the grid spacing details

around as "Extra data" at the end of each field record.

Richard

Richard Hill MBCS CITP Ocean & Coupled Model System Manager
Hadley Centre FitzRoy? Road Exeter Devon EX1 3PB United Kingdom
Tel: +44 (0)1392 884282
Email: richard.hill@…<mailto:richard.hill@…> Website: www.metoffice.gov.uk<http://www.metoffice.gov.uk>


From: Grenville Lister g.m.s.lister@…
Sent: 09 July 2013 10:09
To: Hill, Richard
Subject: HadGEM2 ES

Hi Richard

Could you point me to a good reference for how the ocean grid
works in the ocean model in HadGEM2-ES. A researcher in Leeds
(Julia Tindall) who wants to change the ocean start dump in
some way, but doesn't see how the resolution change towards
the equator is working. I have trawled through the UMDP's but
don't see anything describing how this works.

Many thanks

Grenville

Note: See TracTickets for help on using tickets.