Opened 7 years ago

Closed 7 years ago

#1144 closed help (fixed)

UM run fails because thist file is lacking

Reported by: till Owned by: um_support
Component: UM Model Keywords: modset, thist
Cc: Platform: HECToR
UM Version: 6.1

Description

Dear CMS Team,
I've been trying to find out why a HiGEM run is failing. In the leave file is says:
diff: /work/n02/n02/till/tmp/tmp.hector-xe6-13.11303/xgvwp.xhist: No such file or directory

This leave file is here: /home/n02/n02/till/um/umui_out/xgvwp000.xgvwp.d13277.t114933.leave

Background: in this run I am using a small modset to write out a certain variable to the fort6 files a few times. This modset is here:
/home/n02/n02/till/modset/otk0n601.mf77

But it seems weird that this modset would make the model crash? If I compile without it, everything is fine.

Change History (2)

comment:1 Changed 7 years ago by willie

Hi Till,

The problem is not a missing file. The code runs for 72 time steps and executes your mod for K33 ten times. Then

 PE RANK 60 exit signal Segmentation fault
[NID 00107] 2013-10-04 10:55:06 Apid 5920269: initiated application termination
[NID 00104] 2013-10-04 11:55:24 Apid 5920269: Error detected during page fault processing.  Process terminated via bus error.

So it is executing some code that it shouldn't have, or possibly the code has become too big ("error detected during page fault").

The things to do are to review the mod sets that you've introduced and then if you're satisfied, repeat the run. Make sure that the GNU array is not being accessed out of bounds.

I hope that helps.

Regards

Willie

comment:2 Changed 7 years ago by annette

  • Resolution set to fixed
  • Status changed from new to closed

No response for a while so we're assuming this is sorted.

Annette

Note: See TracTickets for help on using tickets.