Opened 6 years ago

Closed 6 years ago

#1166 closed help (fixed)

Starting a run using a previous CICE restart dump

Reported by: mk1812 Owned by: annette
Component: NEMO/CICE Keywords:
Cc: Platform: MONSooN
UM Version: 8.2

Description

Hi,

I'm using the coupled atmosphere-ocean model on MONSooN (UM vn8.2, NEMO vn.3.4, CICE vn4.1m1). I want to start a new run using the restart dumps from a previous run I've done as the initial conditions, however the CICE restart dumps appear to use the timestep number to define the date, and this is causing the CICE model to initialise with the wrong date. For example, if my previous run was for 31 years from Sep 1999 to Sep 2030, and then I try and start a new run with a start date of Sep 2030, the CICE model thinks that the date is Sep 2061.

The model still runs as an NRUN, but with CICE outputting files with the wrong year, and then if I try and continue it as a CRUN the model detects the mismatch between the timestamps in the CICE files compared with the atmos files, which causes the run to abort.

I have tried editing the CICE namelist to change the istep0 variable to be equal to the timestep number that the CICE dump should already be on, but this did not make any difference. I also tried running the UM reconfiguration, and changing the year_init namelist variable to 1999 instead of 2030, neither of which worked either (the reconfiguration I guess only configures atmos dumps, and the year_init namelist variable gets overridden by the UMUI start date).

Any advice that you could provide on how to start a new run using a CICE dump from a previous integration would be hugely appreciated.

Thanks very much in advance,
Matt

Change History (7)

comment:1 Changed 6 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hi Matt,

When using a CICE dump for a new NRUN you need to reset the date in the file itself. As you've worked out the reconfiguration only works on the atmosphere dump, but there is a tool for CICE on MONSooN:

~aospre/bin/modify_CICE_header

Follow the on-screen prompts to reset the variables according to these instructions:

https://puma.nerc.ac.uk/trac/NEMOCICE/wiki/HowTo/Tools#modify_CICE_header
http://www.ukca.ac.uk/wiki/index.php/Restarting_an_Atmos-Ocean_Integration#4._CICE_restart

You should double check this but I think you need to set istep0 to 0, time to 8*30*24*60*60 for seconds to 1 Sep, and time to 0.

And don't forget to change the file name in the UMUI.

Hopefully this will work.

Annette

Last edited 6 years ago by annette (previous) (diff)

comment:2 Changed 6 years ago by mk1812

Hi Annette,

Thanks very much; that seems to have fixed the problems with the CICE files having the wrong date. However, my job is still failing whenever I try and continue it as a CRUN, which I am a little perplexed by. The error message I get in the .leave file says "The latest NEMO restart dump does not seems to be consistent with the UM .xhist file". It seems as though this failure actually isn't related to the incorrectly dated CICE dumps as I had assumed, since it is still occurring even if I use the original default CICE dump that I used for my previous simulation. Would you have any ideas as to what might be causing this?

Many thanks,
Matt

comment:3 Changed 6 years ago by annette

Hi Matt,

Can you tell me the job-id and location of the .leave file with the error message in it please?

Thanks,
Annette

comment:4 Changed 6 years ago by mk1812

Hi,

Yes, of course - sorry. You could look at either jobs xizkd or xizke. The output .leave files are /home/mkasoa/output/xizke000.xizke.d13315.t152209.leave, or /home/mkasoa/output/xizkd000.xizkd.d13315.t140129.leave.

The jobs are extracted to /projects/ukca/mkasoa/ if that helps as well.

Cheers,
Matt

comment:5 Changed 6 years ago by annette

Hi Matt,

The problem seems to be that because you are using an executable from a different job, the UM isn't picking up the correct scripts. You should select 'Enable build of UM scripts' from Compilation and run optionsUM Scripts Build in the UMUI. Then when you do the NRUN, even though you aren't compiling a new executable, it will still make sure the correct scripts for the job are created. This works for me.

In this case, as a short cut, you can simply copy the bin directory from the base job, eg:
cp -r -p /projects/ukca/mkasoa/xizka/bin /projects/ukca/mkasoa/xizkd
Then resubmit the CRUN and it should work.

Best wishes,
Annette

comment:6 Changed 6 years ago by mk1812

Hi Annette,

Yep, that works now! Thanks very much for looking into that and figuring it out for me!

While I was trying to work out what was going on with these runs, I actually came across another weird problem when I tried to reconfigure the start dump - I had been going to mention it here, since I thought it might have been related, but it would appear that it is actually an unrelated problem so I'll raise it under a new ticket.

Thanks again,
Matt

comment:7 Changed 6 years ago by annette

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.