Opened 6 years ago

Closed 6 years ago

#1173 closed help (completed)

Extract data from MASS

Reported by: pringle Owned by: willie
Component: UM Model Keywords: MOOSE
Cc: Platform: MONSooN
UM Version: <select version>

Description

Hi,

I'd like to extract some data that is stored on MASS, I need one pp file from a job called xeoct. It's stored on Mohit Dalvi's account.

I've not used moose before so I am not sure my settings are correct.

I've have the .moose/moose file.

To see what files are there I've tried:

bash-4.2$ moo ls -lrt :crum/xeoct/apm.pp

And get the error:

ls command-id=122554711 failed: (SSC_TASK_REJECTION) one or more tasks are rejected.

moose:/crum/xeoct/apm.pp: (TSSC_SET_DOES_NOT_EXIST) no such data set.

I've tried various combinations, and one from the wiki page:

bash-4.2$ moo ls -lrt moose:/adhoc/users/aj.watling

ls command-id=122556251 failed: (SSC_TASK_REJECTION) one or more tasks are rejected.

moose:/adhoc/users/aj.watling: (TSSC_UNAUTHORISED) permission denied.

ls: failed (2)

Could you tell me if I already have permission to access the MASS archive, I've never used it before. If so, could you give me an idea how to list the xeoct data? I'm pretty sure it's there.

Thanks for your help,
Kirsty

Change History (4)

comment:1 Changed 6 years ago by willie

  • Keywords MOOSE added
  • Owner changed from um_support to willie
  • Platform set to MONSooN
  • Status changed from new to accepted

Hi Kirsty,

Can you do

moo ls moose:

and get a listing that includes crum? This will tell you if your set up is basically correct. Other than that you will need to know the directory structure under crum. I tried moo ls moose:/crum/xeoc* and found that xeoct was not there.

I believe you have to get permission to access the various accounts - AJ will help there.

Regards,

Willie

comment:2 Changed 6 years ago by pringle

Hi Willie,

Thanks, the moo ls moose gives the following:

moose:/adhoc
moose:/crum
moose:/devfc
moose:/misc
moose:/opfc

So that looks okay, but when I try:

moo ls moose:/crum

I get:

ls command-id=122563942 failed: (SSC_TASK_REJECTION) one or more tasks are rejected.

moose:/crum: (TSSC_UNAUTHORISED) permission denied.

ls: failed (2)

Does it not let you list all the files under crum? You need to know the path?

Thanks,
Kirsty

comment:3 Changed 6 years ago by willie

Hi Kirsty,

You need to get permission to access crum and any subprojects now. It worked for me.

regards,

Willie

comment:4 Changed 6 years ago by willie

  • Resolution set to completed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.