Opened 6 years ago

Closed 5 years ago

#1185 closed help (fixed)

Another segmentation fault in HadGEM2 6.6.3

Reported by: jcrook Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: HECToR
UM Version: 6.6.3

Description

Some time ago I had a segmentation fault in a couple of UM runs of mine (see #1054). The problem was overcome by doubling the atmosphere timestep for 3 months. These runs have crashed several times but the doubling timestep has always worked. However now I have a run based on RCP4.5 but with an ancillary modification to increase the soil albedo in some areas. This has run successfully from 2020 to 2069. I now want to set my soil albedos back to the original values and carry on from Jan 2070. When I did this I had a segmentation fault in Feb 2070. I tried all the things in the previous ticket #1054 but doubling the timestep does not make a difference. The run id is xgeze and the latest .leave file is xgeze000.xgeze.d13343.t161626.leave. In the last timestep (4322) it looks like there are a lot of NaNs? which I don't think happened in other runs.

Change History (3)

comment:1 Changed 6 years ago by willie

  • Keywords segmentation fault removed

Hi Julia,

The job runs for 4321 time steps and then fails to converge on the next due to the presence of NaNs?. These occur in the theta (temperature) variable. This may have something to do with the soil albedos.

Assuming it is an instability issue, you could try creating a dump just before the point of failure and then try to continue after reconfiguring.

Regards,

Willie

comment:2 Changed 6 years ago by jcrook

I set it running again with the dump period set to every month. This time it ran for the 3 months ok. My time step was still set to 144. I have now started from April 2070 with the time step back to 72 and the dump period back to 3 monthly.

comment:3 Changed 5 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.