Opened 5 years ago

Closed 5 years ago

#1190 closed help (completed)

password on hector

Reported by: chollow Owned by: um_support
Component: HECToR Keywords:
Cc: Platform:
UM Version: 7.5

Description

Hi,

I logged in to Hector over the weekend, and it forced me to change my password immediately. Ever since then, my um jobs crash on Hector (although I am able to submit them with no problems from puma). In the leave file for my job on hector, there is a failure of qsserver and it says:

WARNING: Your password has expired.
Password change required but no TTY available.

I tried following advice on an old ticket, and found that when, on puma, I type:

ssh ata27@…

it does not accept my password, and it says:

Permission denied (publickey,keyboard-interactive).

also, I tried:

ssh-add

and got the message:

Could not open a connection to your authentication agent.

However, further following advice on the old ticket, I tried the following:

rm /home/ata27/.ssh/environment.puma

and was told "permission denied", in fact I couldn't even cd into that directory.

Please let me know what to do,
Thanks,
Chris

Change History (6)

comment:1 Changed 5 years ago by chollow

Actually, I realise now that "ata27" is probably the username of the person who wrote the old ticket I was looking at … So, when I tried "ssh chollow@…" it does appear to ssh with no problems from puma to Hector. But this means I still have my problem with jobs crashing on Hector, despite being able to ssh to phase3 without a password from puma.

Chris

comment:2 Changed 5 years ago by jeff

  • UM Version changed from <select version> to 7.5

Hi Chris

The archiving script uses ssh to the lms to copy the files to /nerc, so maybe you also have to update your lms password? Run

ssh lms

on hector and see if it asks you to change your password.

Jeff.

comment:3 Changed 5 years ago by chollow

Hi Jeff,

I just typed "ssh lms" on hector and it just had a normal prompt for password. The password that worked was the new one that I had just changed on hector. So it seems that the password change already went into effect for lmd when I changed my password on hector last weekend.

Chris

comment:4 Changed 5 years ago by jeff

Can you try running the job again.

Jeff.

comment:5 Changed 5 years ago by chollow

Hi Jeff,

I tried running the job again, and it ran fine and completed normally. You can close this ticket now.

Thanks,
Chris

comment:6 Changed 5 years ago by jeff

  • Resolution set to completed
  • Status changed from new to closed

Hi Chris

Ok, that's good. I think it just took some time for the password change to make it to the lms.

Jeff.

Note: See TracTickets for help on using tickets.