Opened 7 years ago

Closed 7 years ago

#1236 closed help (fixed)

Problems moving from Hector to Archer

Reported by: cwright Owned by: um_support
Component: Other Keywords: hector, archer, qsub,
Cc: Platform: ARCHER
UM Version: 6.6.3

Description

Hi,

I'm running into a problem moving my jobs from Hector to Archer. I've tried to follow the instructions at http://cms.ncas.ac.uk/wiki/Archer; specifically, I've:

(1) copied my .profile from Hector to Archer
(2) changed Model Selection → Submodel Independent → Target Machine → 'Other machine name' to login.archer.ac.uk

(the job I've tried it with is xiwxa). It appears to build fine on Puma, but when it submits to Archer I get the attached screenshot as a response.

I suspect what I'm getting wrong is probably something fairly basic, so hopefully easily fixed! I guessed it was missing environment variables, so I tried adding

export UMDIR=/work/n02/n02/hum

to my Archer .profile and changing vn to 6.6.3 (also in .profile), but that didn't seem to fix it so I've put it back as it was on Hector.

Attachments (1)

Screenshot 2014-02-27 18.37.04.png (12.3 KB) - added by cwright 7 years ago.
screenshot of error message

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by cwright

screenshot of error message

comment:1 Changed 7 years ago by grenville

Corwin

Please give us permission to read your home and work spaces on ARCHER.

Grenville

comment:2 Changed 7 years ago by cwright

Hi Grenville,

They should now be chmodded them to be world- and group-readable. Sorry for the delay, lots of meetings today!

comment:3 Changed 7 years ago by ros

Hi Corwin,

We still can't see you /home or /work directories. Please run

chmod -R g+rX /home/n02/n02/cwright
chmod -R g+rx /work/n02/n02/cwright

Cheers,
Ros.

comment:4 Changed 7 years ago by cwright

Done - sorry, I'd given you r but not x, forgetting you needed that to open directories!

comment:5 Changed 7 years ago by ros

What you attempted as a fix was entirely correct, but just missing one thing. As you said you need to set $UMDIR and change VN from 7.1 to 6.6.3. The only catch is the UM directory for 6.6.3 is $UMDIR/hg6.6.3 so you also need to change the if statement.

So in your ARCHER .profile you should have:

export UMDIR=/work/n02/n02/hum
TARGET_MC=cce  #for phase3
VN=6.6.3
if test -f $HOME/.umsetvars_$VN; then
. $HOME/.umsetvars_$VN
else
. $UMDIR/hg$VN/$TARGET_MC/scripts/.umsetvars_$VN

Cheers,
Ros.

comment:6 Changed 7 years ago by cwright

Hi Ros,

yep - that's submitted fine now, and is compiling on Archer. Thanks!

Corwin

comment:7 Changed 7 years ago by cwright

Additional comment addressed to anyone reading this to de-bug a similar problem in future: after implementing Ros' fix, I was able to compile, but the model immediately crashed on the first timestep with the error

/work/n02/n02/cwright/xiwxw/bin/qsexecute[424]: aprun: not found [No such file or directory]

I was able to fix this by adding the lines

. /etc/profile
. /etc/bash.bashrc

(from http://cms.ncas.ac.uk/ticket/1217) to my .profile as well as those above - the model now seems to be running.

(There's also a very small typo in Ros' .profile addition: you need to add a 'fi' to the end to close the if loop.)

comment:8 Changed 7 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for updating this ticket with the further changes required.

Note: See TracTickets for help on using tickets.