Opened 7 years ago

Closed 7 years ago

#1250 closed help (fixed)

GC2 NEMO/CICE output

Reported by: wx019276 Owned by: annette
Component: UM Model Keywords: GC2, archiving, coupled model, nemo, cice
Cc: Platform: MONSooN
UM Version: 8.4

Description

I am using GC2 on MONSooN through puma (job id xjhb*) I have done a few test runs and I am ready to set of a longer run. However I am confused by the standard output from NEMO and CICE - I have tried to find this online but I can't find a relevant website - perhaps you know of one?

I am not getting any ocean output archived to MASS at the very least I would like the monthly means of the ocean and ice data. I do get ice data which is *.1m.* - is this the only output or is there other CICE output that isn't being archived?

So I guess my question is two-fold
(1) what output from NEMO & CICE should I expect and
(2) how can I get this to archive to MASS (there doesn't seem to be any options in the umui to change the output for NEMO and CICE.)

Thanks in advance for your help,
Ruth


Change History (8)

comment:1 Changed 7 years ago by annette

Hi Ruth,

The CICE diagnostic output all goes to the *.1m.* files, and the NEMO diagnostics go to files named *grid_[TUVW]*.

If you want to change the fields that are output, you can control this through the CICE namelist ice_in, and a combination of the NEMO namelist and pre-processor flags. There is probably some information about this on the NEMO website - http://www.nemo-ocean.eu/ - you do however need to register to see most of the content.

I am not sure how the archiving works on Monsoon as we don't have access to MASS, so I'm going to pass that on to a Monsoon person for you…

Annette

comment:2 Changed 7 years ago by wx019276

Hi Annette,

Great thanks, in that case it looks like I have all the CICE output and it has been archived to MASS fine.

I think I don't need to make any changes to NEMO output - the issue simply is that it is not archiving to MASS in the same way that the atmosphere and ice data is, so yes I think that is a question for the MONSooN people.

Thanks,
Ruth

comment:3 Changed 7 years ago by annette

  • Keywords GC2, archiving, coupled model, nemo, cice added
  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hi Ruth,

Just to give you a bit more info:

  • Archiving is controlled in the UMUI panel : "Post processing → Main switch and general questions". In here it looks like you should change the MONSooN group from 'umadmin' to your project group 'pppcc'. Although if you are getting some things archived then this may be a red herring.
  • The NEMO/CICE post processing is set here : "Atmosphere → Control → Post processing, dumping and meaning → User script releases" - not the most obvious location! Every so often separate jobs will be launched to process and archive the NEMO and CICE output.

Annette

comment:4 Changed 7 years ago by wx019276

Hi Annette,

Ok great thanks I will change that and see if it sorts the problem.

Will let you know.

Thanks,
Ruth

comment:5 Changed 7 years ago by wx019276

Hi Annette,

Just to let you know that I changed the group in post processing, main switch, to pppcc, but this doesn't seem to have made any difference.

For your second point I see that there is a cice_archive.sh but not one for nemo - so I am assuming that is may be what is missing. Since no archiving of the nemo data is occurring either there need to be a similar nemo_archive.sh or it is in the nemo_cron_process.sh but it isn't working right. Hopefully Jeremy can let us know.

Thanks for your help,
Ruth

comment:6 Changed 7 years ago by annette

Hi Ruth,

Well if you difference nemo_cron_process.sh and nemo_archive.sh the only differences look like MOOSE archiving so I'd try switching those scripts. Like I say we can't test this, so best just to give it a go.

Annette

comment:7 Changed 7 years ago by wx019276

Hi,

Ok thanks, I will try it and see what it does, hopefully that will work.

Thanks,
Ruth

comment:8 Changed 7 years ago by annette

  • Resolution set to fixed
  • Status changed from assigned to closed

Hi Ruth,

You confirmed offline that this worked so I'm going to close the ticket. I'll answer your other queries separately.

Annette

Note: See TracTickets for help on using tickets.