Opened 6 years ago

Closed 6 years ago

#1259 closed help (fixed)

Permission denied error when submitting a job to ARCHER

Reported by: eelsj Owned by: ros
Component: UM Model Keywords:
Cc: Platform: PUMA
UM Version: 6.6.3

Description

Hi,

I'm trying to compile/run a job (XJKOF) on ARCHER for the first time. The job is a copy of XJKOC which I ran on Hector.

I get a permission denied error in PUMA when submitting the job.

I have an account on ARCHER (eelsj), have set the target machine in XJKOF to login.archer.ac.uk, copied the authorised_keys file from Hector to ARCHER and copied the .profile file to ARCHER adding the 2 lines as per http://cms.ncas.ac.uk/wiki/Archer.

I changed my ARCHER password yesterday, I don't know if it takes time to be fully implemented. Can you help, please?

Thank you
Lawrence

Change History (9)

comment:1 Changed 6 years ago by ros

Hi Lawrence,

Are you able to ssh from PUMA to ARCHER without it prompting for a password/passphrase?

Regards,
Ros.

comment:2 Changed 6 years ago by eelsj

Hi Ros,

Yes.

Lawrence

comment:3 Changed 6 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Lawrence,

I'm rather confused at the moment as this job has given absolutely no output on PUMA, the extract hasn't even started.

Can you send me the following:

1) The output you get in the UMUI submission window
2) If there are any error windows can you send me the stack trace
3) And also any output that appears in the command line window from which you started the UMUI.

Also can you please change permissions on your ARCHER /home & /work directories so that we can see them.

chmod -R g+rX /home/n02/n02/eelsj
chmod -R g+rX /work/n02/n02/eelsj

Cheers,
Ros.

comment:4 Changed 6 years ago by ros

Hi Lawrence,

Just seen what the problem is, your account is under e187 on ARCHER. You need go into SAFE and request that your account is under n02.

Regards,
Ros.

comment:5 Changed 6 years ago by eelsj

Hi Ros,

1) Output I get in the UMUI submission window:

ERROR: login.archer.ac.uk: Permission denied

2) Stack trace:

STACK-TRACE:
login.archer.ac.uk: Permission denied

while executing

"error $err"

(procedure "um_nav_submit" line 23)
invoked from within

"um_nav_submit"

(command bound to event)

3)No command line error messages

I have been set-up on ARCHER with the directory /home/e187/e187/eelsj (no /work/e187/e187/eelsj) and nothing under n02.

Just seen your latest message. I'll request the change on SAFE and try again.

Thanks,
Lawrence

comment:6 Changed 6 years ago by eelsj

Hi Ros,

I now have an ARCHER account under n02 and that has cured the "permission denied" error.

I am still struggling to submit a job however. With the original tic-code n02-iagp I receive the message:

qsub: ARCHER: budget n02-iagp has no time left

SAFE shows: Hector 752.5 kAUs for n02-iagp and 4952.1 kAUs for e187

ARCHER 0.0 kAUs for n02

Should I be using a different tic-code or can the time allocation be moved to ARCHER?

Thank you

Lawrence

comment:7 Changed 6 years ago by ros

Hi Lawrence,

Unfortunately AUs cannot be transferred from HECToR to ARCHER. We have just put some time allocation into n02-iagp, this may take a little while to take effect.

Until we receive the budget allocations for ARCHER at the beginning of April we have limited time available on ARCHER, so please don't run any production type runs yet.

Regards,
Ros.

comment:8 Changed 6 years ago by eelsj

Hi Ros,

Okay, I'll limit my runs to a minimum level of testing for now.

Thanks for your help.

Lawrence

comment:9 Changed 6 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.