Opened 5 years ago

Closed 5 years ago

#1270 closed help (fixed)

Porting job from MONSooN to ARCHER

Reported by: hn110 Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.2

Description

Hello,

I am trying to port a job from MONSooN to ARCHER and could do with some advice on the changes that are needed. I have not run the UM before. The job is xizk.a belonging to user mk1812. I would like to keep the physical setup from this job (model physics, resolution etc). Please could you advise?

Many thanks,
Hannah Nissan
(Imperial College London)

Change History (6)

comment:1 Changed 5 years ago by grenville

Hannah

Please see http://cms.ncas.ac.uk/wiki/Faq/ConvertMonsoonJobToHector - the page refers to HECToR, but since HECToR and ARCHER are very similar, the advice still applies.

We are currently working to implement archiving on ARCHER, so that won't yet work.

I'd advise you to run through the UM training exercises (http://cms.ncas.ac.uk/documents/training/um_practicals/) to gain some experience with the UM before trying to run models in earnest.

Grenville

comment:2 Changed 5 years ago by hn110

Hi Grenville

Thanks for getting back to me. I'm working through the practical example via the link you sent (PUMA-ARCHER part 1). I have gone through the process and submitted the job, but the model fails to compile. I think this is because it runs out of time. When I type qstat -u hn110 it says it has been allocated 1hr, which it uses up and then stops. The *.comp.leave file says 'walltime exceeded' just before it stops.

The problem is I can't find where the wall time was requested. I tried playing with the Job time limit (General details→ Submit) but this had no effect (it was set to 1200 anyway which is less than an hour). I also don't understand the difference between the job submission options (load leveller, qsub etc).

Also, the tutorial says that the environment variable $WORKDIR is set in .profile, which I copied from ~grenvill/.profile as suggested. Can you tell me where this is set please?

Thanks very much, sorry for all the questions!

Hannah

comment:3 Changed 5 years ago by ros

Hi Hannah,

The compile time limit is set in the UMUI window Compilations and Modifications → Compile options for the UM.

The job time limit that you tried changing controls the time limit for running the UM executable that the compilation step produces.

The job submission options (loadleveler, qsub, etc) relate to the job scheduling system that runs on the HPC. Different machines use different schedulers. ARCHER uses qsub, MONSooN uses loadleveler.

$WORKDIR is set via the UM script $UMDIR/vn7.3/cce/scripts/.umsetvars_7.3 which is called from your .profile.

Hope that help.
Cheers,
Ros.

comment:4 Changed 5 years ago by hn110

Thank you Ros. The model now compiles fine, but won't actually run. It says qsub: Unknown queue. I haven't changed any of the submission settings from the original job (grenville xjpb.a). Do you know where this error might be coming from?

comment:5 Changed 5 years ago by ros

Hi Hannah,

You need to go to UMUI window Input/Output control and resources → User hand-edit files and switch off the hand-edit .../reserve_monday by changing the Y to an N. This hand-edit changes the queue to use a reservation that we have activated only during a training course.

Regards,
Ros.

comment:6 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
  • UM Version changed from <select version> to 8.2
Note: See TracTickets for help on using tickets.