Opened 6 years ago

Closed 5 years ago

#1289 closed help (answered)

Pumf/Cumf errors on Polaris

Reported by: isssjp Owned by: um_support
Component: UM Tools Keywords: pumf cumf
Cc: a.m.dolan@… Platform: Other
UM Version: 4.5

Description

Hello,

We are trying to use the pumf and cumf utilities on Polaris. Grenville Lister has installed these for us, but we are not sure why they are not working. We are trying to use them on ancillary files that we know run successfully in the UM to test it initially.

The error message we are getting is:
/home/polaris_lds1/earhum/PUM64/um/vn4.5/utils/pumf: line 141: 57706 Segmentation fault

We have tried swapping the bytes in the file, but that made no difference. If you have any ideas it would be really helpful.

Thanks,
Steven

Change History (4)

comment:1 Changed 6 years ago by grenville

Steven

I think Gethin installed the 4.5 utilities - I will forward your message to him as a first step. I'm assuming that pumf and cumf work on ARC? I can't remember if ARC and Polaris are similar enough that you could try copying a working pumf from ARC to Polaris - I daresay you've already tried that 'though.

Grenville

comment:2 Changed 6 years ago by isssjp

Hi,

Yes, we have already tried the versions on arc, but they don't work either. It was working on hector though, which is where we were using it before. Gethin is quite busy so it may take him a long time to reply. Is it possible to give me the source code so that I can recompile it.

Steven.

comment:3 Changed 6 years ago by grenville

Steven

The source is all on Polaris

/home/polaris_lds1/earhum/PUM64/um/vn4.5/exec_build/pumf_dir

there's a makfile there too.

/home/polaris_lds1/earhum/PUM64/um/vn4.5/utils/pumf is the script which calls the pumf executable.

Grenville

comment:4 Changed 5 years ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.