Opened 6 years ago

Closed 6 years ago

#1309 closed error (completed)

Compilation error for UM VN7.3 in ARCHER

Reported by: oma Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.3

Description

Hello,

I'm trying to compile the standard code of the UM just to get started with ARCHER but I'm getting the following error.

Build command finished on Wed Jun 11 11:09:29 2014.
Base build: OK
Build command started on Wed Jun 11 11:09:30 2014.
->Parse configuration: start
Config file (bld): /home/n02/n02/oma/xjzma/ummodel/cfg/bld.cfg
Config file (bld): /home/n02/n02/oma/xjzma/umbase/cfg/bld.cfg
->Parse configuration: 3 seconds
->Setup destination: start
Destination: oma@esPP001:/home/n02/n02/oma/xjzma/ummodel
->Setup destination: 0 second
->Setup build: start
->Setup build: 1 second
->Pre-process: start
No. of files scanned for PP dependency: 2814
ftn-2105 crayftn: ERROR in command line
  "-P" is an invalid command-line option.
[FAIL] ftn -P -E -DC_LOW_U=c_low_u -DFRL8=frl8 -DLITTLE_END=little_end -DC_LONG_INT=c_long_int -DMPP=mpp -DLINUX=linux -DXT4=xt4 -DCONTROL=control -DREPROD=reprod -DMPP=mpp -DATMOS=atmos -DA04_ALL=a04_all -DA01_3A=a01_3a -DA02_3A=a02_3a -DA03_8C=a03_8c -DA04_3D=a04_3d -DA05_4A=a05_4a -DA06_4A=a06_4a -DA08_7A=a08_7a -DA09_2A=a09_2a -DA10_2B=a10_2b -DA11_2A=a11_2a -DA12_2A=a12_2a -DA13_2A=a13_2a -DA14_0A=a14_0a -DA15_1A=a15_1a -DA16_1A=a16_1a -DA17_0A=a17_0a -DA18_0A=a18_0a -DA19_1A=a19_1a -DA25_0A=a25_0a -DA26_0A=a26_0a -DA30_1A=a30_1a -DA31_1A=a31_1a -DA32_1A=a32_1a -DA33_0A=a33_0a -DA34_0A=a34_0a -DA35_0A=a35_0a -DA38_0A=a38_0a -DA70_1B=a70_1b -DA71_1A=a71_1a -DC70_1A=c70_1a -DC72_0A=c72_0a -DC80_1A=c80_1a -DC82_1A=c82_1a -DC84_1A=c84_1a -DC92_2A=c92_2a -DC94_1A=c94_1a -DC95_2A=c95_2a -DC96_1C=c96_1c -DC97_3A=c97_3a -I/home/n02/n02/oma/xjzma/ummodel/inc -I/home/n02/n02/oma/xjzma/umbase/inc rcf_parvars_mod.F90 failed (1) at /fs2/n02/n02/hum/fcm-2014-02/bin/../lib/FCM1/BuildSrc.pm line 750

Model build: failed

My job is xjzma. The job is a copy from a HECToR job and I've included the overrides suggested in the NCAS-CMS ARCHER page.

Any help would be much appreciated.

Regards,

Oscar

Change History (2)

comment:1 Changed 6 years ago by oma

Please ignore this messages. I have solved the problem. It was that I had included some overrides but not the correct one. I have corrected this and now the model compilation is running fine.

Thanks and apologies,

Oscar

comment:2 Changed 6 years ago by grenville

  • Resolution set to completed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.