Opened 5 years ago

Closed 5 years ago

#1314 closed help (fixed)

Faster UM compilation?

Reported by: swr04ojb Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.5

Description

Hello,

at the moment each time I submit job xini#b to ARCHER the model is compiled, then the reconfiguration step is done, then the job itself is run. The compilation step usually takes a little under an hour (though if the machine is slow it can be longer). This makes for a slow development process, and I'm sure I must be doing something not quite right — is there a quicker way to compile that I've overlooked? One that would only re-compile the bits that I'm changing and anything that depends on them, e.g. could I just run Make locally on ARCHER?

kind regards,

oliver

Change History (3)

comment:1 Changed 5 years ago by grenville

Hi Oliver

Slow compilation in the serial queues is a problem which ARCHER are working on. I see from your job xinib that you are requesting a full extract and build each time. If you change the settings in FCM Configuration→FCM Extract directories and Output levels to not require full extract and build, then only incremental changes will be processed. If this still results in slower than acceptable builds, you can go to your "ARCHER extract directory"/umatmos/cfg and type fcm build. This will do an interactive incremental build - note the executable will live in "ARCHER extract directory"/umatmos/bin - you will need to either move it to where the umui expects it, or change to umui to look for it here.

I encourage you to alert ARCHER to your dissatisfaction with the slow builds through the serial queues. While they are working on the issue, the more they understand how the problem is impacting the community, the better.

Grenville

comment:2 Changed 5 years ago by ros

Hi Oliver,

Further to what Grenville says above, rather than manually running fcm build it will be easier to go to your ~/umui_runs/<job-directory> on ARCHER and run the script ./umuisubmit_compile. This will automatically set up your fcm environment, do the incremental compile by running fcm build and copy the executable to it's correct location.

Cheers,
Ros.

comment:3 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

Further to the above I should also have said that you will need to submit the job as normal to get the ~/umui_runs/<job-directory> directory onto ARCHER and then delete the compile job from the queue using qdel <qsub-id>, before running the ./umuisubmit_compile script.

Note: See TracTickets for help on using tickets.