Opened 5 years ago

Closed 5 years ago

#1342 closed help (answered)

can't submit jobs to monsoon - umui says my passcode isn't valid, although it is

Reported by: bs Owned by: ros
Priority: normal Component: UM Model
Keywords: Cc:
Platform: PUMA UM Version: 8.2

Description

Dear help, I can't submit jobs to monsoon - the umui says my passcode isn't valid, although it is as I can login to monsoon directly, and also PUMA has copied files belonging to the job across to monsoon

Thanks for your help,

Bablu

Change History (6)

comment:1 Changed 5 years ago by bs

forgot to mention, the job is xjhie - note that job xjhid submits itself with no problem, but not xjhie…

comment:2 Changed 5 years ago by ros

Hi Bablu,

Can you cut and paste the exact error message you are getting from the UMUI please? It's failed part way through sync'ing source files from MONSooN which is strange. The reason your xjhid job submits fine is because it is a run only job and so there is no copying over of the source code required.

Regards,
Ros.

comment:3 Changed 5 years ago by bs

Hi Ros, I got the following in a new window:

ERROR: Timed out, lander.monsoon-metoffice.co.uk not responding while attempting to access account basinh on host ibm02. Note that repeated failures may result in expiry of password due to security procedures on some machines. Check user id, hostname and password for your account on the host machine.

and in the submission window, it ends with

Timed out, lander.monsoon-metoffice.co.uk not responding

seems to be something to do with rsync as you say…

Best wishes, Bablu

comment:4 Changed 5 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Bablu,

I feared it might be that error message. :-( This is one that can be intermittent and can be caused by many things, so it's a process of elimination.

First of all I would suggest just trying to resubmit and see if the problem is still there today.

I will ask the MONSooN guys to check that there's not something odd happening at their end. It can also be due to problems with the ssh-agent trying to connect back to PUMA from MONSooN. Are you being prompted at any point during submission for your PUMA password?

Assuming you are still getting the problem today can you also please try shutting down the UMUI and then run the command export UMUI_SSH_DEBUG_LEVEL=5 in a PUMA terminal window and then restart the UMUI from that same terminal window. Resubmit the job and you should then get a lot of information echo'd to the terminal window. If you could then put that output into a file somewhere on PUMA I'll take a look and see if I can identify what's going on.

Cheers,
Ros.

comment:5 Changed 5 years ago by bs

Hi Ros, just tried again and it submitted OK and is processing! File under mysterious I guess - I will let you know if it happens again. Is there any mileage in running the diagnostics you suggested anyway in case it points to a reason for this behaviour?

Best wishes, Bablu

comment:6 Changed 5 years ago by ros

  • Resolution set to answered
  • Status changed from accepted to closed

Hi Bablu,

The diagnostics only detail what ssh is up to during submission, so there isn't really any point running it unless you are consistently getting the submission problem.

Please do let me know if you get this problem again.

Regards,
Ros.

Note: See TracTickets for help on using tickets.