Opened 5 years ago

Closed 5 years ago

#1348 closed help (completed)

Getting nudged UKCA running

Reported by: fcentoni Owned by: luke
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.3

Description

Hi,

I am still trying to get UKCA running in a nudged configuration.
I followed P. Telford wiki instructions as strictly as possible.

Considering that the only 365 ancillary files currently available are for the N96 resolution, I created a new branch from Luke's one um_br/dev/luke/VN7.3_UKCA_CheM branch@13783.

However, the job failed twice during compilation.
This is the error I get:

ERROR: /home/n02/n02/fcentoni/um/xketa/ummodel/cfg/bld.cfg: LINE 45:
       tool::fflags::UM::atmosphere::UKCA::asad_chem_flux_diags: invalid sub-package in declaration.
Build failed on Fri Aug 15 16:43:13 2014.

Many thanks.
Kind regards,
Federico.

Change History (10)

comment:1 Changed 5 years ago by ros

Hi Federico,

Your compilation is failing as it can't find the file UM/atmosphere/UKCA/asad_chem_flux_diags.F90 because you haven't included your branch properly.

You have merged in Luke's VN7.3_UKCA_CheM branch into your working copy for branch fcm:um_br/dev/fcentoni/vn7.3_UKCA_nudged_ddep but you haven't committed the changes to the repository so including the branch in the modifications table is doing nothing. You either need to commit your working copy and update the revision number in the table or enable "Include modifications from user working copy" and specify the path to your working copy.

Cheers,
Ros.

comment:2 Changed 5 years ago by fcentoni

Dear Ros,

thank you, I have done that.
It seems now there may be something wrong with the start dump.

 *****************************************************************************
 ERROR!!! in reconfiguration in routine Setup_LSM_Out
 Error Code:-  50
 Error Message:- Number of land points does not agree with input namelist!
 Error generated from processor  0
 *****************************************************************************
Rank 0 [Mon Aug 18 13:20:50 2014] [c3-1c2s14n3] application called MPI_Abort(MPI_COMM_WORLD, 9) - process 0
_pmiu_daemon(SIGCHLD): [NID 02299] [c3-1c2s14n3] [Mon Aug 18 13:20:50 2014] PE RANK 13 exit signal Aborted
[NID 02299] 2014-08-18 13:20:50 Apid 9824701: initiated application termination
/work/n02/n02/fcentoni/um/xketa/bin/qsexecute: Error in dump reconfiguration - see OUTPUT

As start dump I have left the one for N48L60 that is xegwe.astart.
Is there any appropriate start dump I am supposed to point to for N96 resolution?

Something like 'paahs.astart' you can find on Archer at:

/work/n02/n02/ukca/ANCILS/N96L38/initial

or anyone at,

/work/n02/n02/ukca/ANCILS/ASTART

Many thanks.
Kind regards,
Federico

comment:3 Changed 5 years ago by luke

  • Owner changed from um_support to luke
  • Status changed from new to accepted

Hi Federico,

It is quite a complicated job to take a N48L60 model and turn it into a N96L38 model, and I would not recommend it. I suggest adapting the ancillaries in your N48 job so that they work with nudging, if you need to do this. However, you should be able to use your existing ancillaries, for the present at least, to check that the method is working.

Can I suggest following the instructions at http://www.ukca.ac.uk/wiki/index.php/Nudging#Getting_Working_at_UM7.3 but ignoring point 2A, as this explicitly states "Ignore if retain exisiting ancillary files".

Please try getting nudging to work using the existing ancillaries, and then if you have problems with this you add them here.

Thanks,
Luke

comment:4 Changed 5 years ago by fcentoni

i Luke,

I am trying to create a new ancillary file for 365 calendar using an existing N48 ancillary file for 360 calendar.

I made two copies of the O3 and SST files from the folder /work/n02/n02/ukca/hadgem3/ancil/atmos_n48> available on Archer into my home.

Then I converted all the fields into a .nc file and I set-up all the options in Xancil.
However when I try to create a new ancillary file I get the error message:

"Error:couldn't open "/fs2/n02/n02/hum/bin/xancil.namelist": permission denied"

Any suggestion?

Many thanks.
Cheers,
Federico

comment:5 Changed 5 years ago by luke

Hi Federico,

I'm not quite sure about that Xancil error - Jeff may be able to comment on that more. I'm wondering if Xancil thinks that it's working directory is /fs2/n02/n02/hum/bin/ rather than one of your directories. Have you tried saving a .job file?

Also, I don't believe that you need to make up new ancillaries in the first instance. The webpage above does explicitly state "Ignore if retain exisiting ancillary files". Can you try just making the UMUI changes, without changing any ancillary files?

Thanks,
Luke

comment:6 Changed 5 years ago by fcentoni

Hi Luke,

Yes I tried to save a.job file and it gives me my home path.

I wish I could make some progress if my job didn't fail again. It turned to be segmentation fault once more.

Thanks.
Federico

comment:7 Changed 5 years ago by fcentoni

Hi Luke,

I successfully run for 2 months with the 360 calendar retaining 360 ancillaries (job xketa).

I also attempted to run with 365 calendar making new 365 ancillaries.

I actually copied some of the 365 ancillary files currently available (for the N96 version) into the folder N48_ancil365 in my Archer home.
Then I re-gridded them following the method you explained in the UKCA tutorial 5 in order to create 365 ancillary files for the N48 version.
It turned out that the model failed. Looking at the xketb000.xketb.d14246.t180230.leave file you can read:

*********************************************************************************
 UM ERROR (Model aborting) :
 Routine generating error: INITIAL
 Error code:  1
 Error message:
INANCLA: Error opening file
 *********************************************************************************
Could it be due to the ancillary files I made? or anything else?

Many thanks.
Federico.
 

comment:8 Changed 5 years ago by luke

Hi Federico,

Is this still a problem?

As I stated above, you shouldn't need to remake any ancillary files, as these will be monthly at the moment in any case. If you are using daily ancillary files then these would need to be remade.

Using N96 ancillary files will not be possible without regridding.

Thanks,
Luke

comment:9 Changed 5 years ago by fcentoni

Hi Luke,

This is not a problem anymore.

Thank you,
Federico.

comment:10 Changed 5 years ago by luke

  • Resolution set to completed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.