Opened 12 years ago

Closed 12 years ago

#137 closed help (fixed)

Number of processors does not fit

Reported by: hanneke Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hello,

I have a problem with one of my runs where I get the error:

*
ERROR!!! in reconfiguration in routine Rcf_Initialise
Error Code:- 50
Error Message:- Total number of processors does not fit EW/NS LPG
Error generated from processor 0
*
gc_abort (Processor 0 ): Job Aborted from Ereport
*
ERROR!!! in reconfiguration in routine Rcf_Initialise
Error Code:- 50
Error Message:- Total number of processors does not fit EW/NS LPG
Error generated from processor 1
*

…etc…

I'm using settings that I have used before. To be sure, I reran a job that used to run fine - but now shows the same error. I'm using 4 processors East-West, and 8 North-South. Even after playing around with those values I keep getting the error.

Do you have any advice on what to change to get around this error?
Thanks a lot!
Hanneke

Change History (7)

comment:1 Changed 12 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to assigned

Hi Hanneke

Do the number of processors used for the UM match the number used for the reconfiguration? The number of reconfiguration processors is set in umui window

Reconfiguration → General Reconfiguration Options

Is this job on puma? If it is and you are still having problems can your give me the umui jobid.

Jeff.

comment:2 Changed 12 years ago by hanneke

Hi Jeff,

Actually it was set not to use multiple processors for the reconfiguration. I have changed it now to the same as used for the UM (4 EW and 8 NS) and tried again. This time it does produce an .astart file, but the data in it is corrupt. This is the error it gives:

/hpcx/tmpchkpt/jtmp/l1f401.346592.0/tmp/modscr_xdbfc/qsexecute: Executing dump reconfiguration program /hpcx/devt/n02/n02-ncas/hanneke/xdbfc/xdbfc.reconf

ATTENTION: 0031-408 32 tasks allocated by LoadLeveler?, continuing…
ERROR: 0031-250 task 0: Segmentation fault

Without an obvious error message… The umui jobid is xdbfc.

Thanks a lot for your help!
Hanneke

comment:3 Changed 12 years ago by jeff

Hi Hanneke

You need to set the environment variable XLFRTEOPTS="namelist=old:buffering=disable_all" in the umui, see helpdesk query #69. There should then be a useful error message in the .leave file.

Jeff.

comment:4 Changed 12 years ago by hanneke

Hi Jeff,

I have done what you suggested, but I don't get useful information. They all say:

*
WARNING in reconfiguration in routine rcf_h_int_init_bl
Warning Code:- -10
Warning Message:- Interpolating ozone from zonal to full field
Warning generated from processor 7
*

But I don't think this is what is causing the segmentation fault. I have seen this warning in all my runs and it never seemed to be a problem for the run.

Do you have any idea what the problem could be?
Thanks a lot,
Hanneke

comment:5 Changed 12 years ago by hanneke

Hi Jeff,

Have you had a chance to look at the problem with my run? I'm still having the same problem. Basically the run crashes with a segmentation fault and I don't understand why. I hope I'm just overlooking something simple…

Thanks a lot,
Hanneke

comment:6 Changed 12 years ago by lois

  • Owner changed from jeff to lois
  • Status changed from assigned to new

Jeff is on holiday for 2 weeks so I will have a look at your problem Hanneke.

Lois

comment:7 Changed 12 years ago by lois

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.