Opened 5 years ago

Closed 5 years ago

#1382 closed help (fixed)

Unable to start UKCA tutorial runs

Reported by: CatherineHardacre Owned by: ros
Component: PUMA Keywords: ssh-agent
Cc: Platform: PUMA
UM Version:

Description

Hi,

I am attempting to run the UKCA tutorial experiment. However, shortly after submitting the run through the umui, I get the following error:

MAIN_SCR: Calling Extract …
Extracting UMSCRIPTS including any branches…
UMSCRIPTS extract failed
See extract output file /home/CatherineHardacre/um/um_extracts/xkdea/umscripts/ext.out
MAIN_SCR: Extract failed
MAIN_SCR stopped with return code 255

From the ext.out file:

Permission denied (publickey,keyboard-interactive).
[FAIL] ssh -n -oBatchMode=yes chardacr@… mkdir -p /home/n02/n02
/chardacr/um/xkdea/umscripts/cfg failed (255) at /home/um/fcm-2014-02/bin/../lib
/FCM1/Dest.pm line 756.

I am not sure why permission is being denied, I am able to log in to Archer as normal. Please let me know if I actually need to submit a query to Archer support instead.

Thank you for your help.

Kind Regards,

Catherine Hardacre

Change History (5)

comment:1 Changed 5 years ago by ros

Hi Catherine,

Just to confirm when you ssh from PUMA to ARCHER you are not prompted for a password or passphrase?

Can you also please give us permission to view your /home and /work directories on ARCHER by running:

chmod -R g+rX /home/n02/n02/chardacr
chmod -R g+rX /work/n02/n02/chardacr

Regards,
Ros.

comment:2 Changed 5 years ago by CatherineHardacre

Hi Ros,

I have added the permissions on the /work and /home directories for Archer.

I am prompted for the pass phrase (which I set up when I transferred my Hector account to Archer) when I submit the run, but not only the first time I submit a run after having logged out of Archer and PUMA.

Catherine

comment:3 follow-up: Changed 5 years ago by ros

  • Component changed from UM Model to PUMA
  • Keywords ssh-agent added
  • Owner changed from um_support to ros
  • Platform set to PUMA
  • Status changed from new to accepted
  • UM Version <select version> deleted

Hi Catherine,

Ok. You need to get your ssh set up so it doesn't prompt for a password or passphrase. Since it is prompting for a passphrase it looks like you have the keys set up ok. Please try running ssh-add on PUMA. It should prompt for your passphrase. If it doesn't and you get an error message like "Couldn't open connection to your authentication agent" please follow the instructions here

After running 'ssh-add' successfully, check you don't get prompted for a password/passphrase by logging into ARCHER from PUMA.

Cheers,
Ros.

comment:4 in reply to: ↑ 3 Changed 5 years ago by CatherineHardacre

Replying to ros:

Hi Catherine,

Ok. You need to get your ssh set up so it doesn't prompt for a password or passphrase. Since it is prompting for a passphrase it looks like you have the keys set up ok. Please try running ssh-add on PUMA. It should prompt for your passphrase. If it doesn't and you get an error message like "Couldn't open connection to your authentication agent" please follow the instructions here

After running 'ssh-add' successfully, check you don't get prompted for a password/passphrase by logging into ARCHER from PUMA.

Cheers,
Ros.

Hi Ros,

Thank you for your help! I seem to be able to get things stated now.

Kind Regards,

Catherine

comment:5 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.