Opened 5 years ago

Closed 5 years ago

#1384 closed help (fixed)

cray-libsci/13.0.1 is not compatible with cce/8.2.1

Reported by: oma Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.3

Description

Hello,

I'm trying to compile a version of the UM vn7.3 with modified code through FCM. I'm getting the following error:

Error:
cray-libsci/13.0.1 is not compatible with cce/8.2.1.

Either:
module swap cray-libsci cray-libsci/(older than 13.0.0) or
module swap cce cce/(8.3.0 or newer)

fcm_internal compile failed (256)

This is just a different version of another job that compiled fine two days ago, and I haven't changed anything in my .profile file or anything like that, so I'm guessing this is related to some very recent changes to the compilers? Is there a known way to fix this?

The job is xkmcv in ARCHER.

Regards,

Oscar

Change History (4)

comment:1 Changed 5 years ago by jeff

Hi Oscar

This problem was caused by the default modules being changed on archer. I have put in a fix and I'm testing it at the moment. You could try to compile your job again and let me know whether it works.

Jeff.

comment:2 Changed 5 years ago by oma

Hi Jeff,

It's compiling now so it seems the error is gone. I'll let you know the final result once it finishes.

Thanks,
Oscar

comment:3 Changed 5 years ago by oma

Hi Jeff,

The compilation has been completed successfully now.

Thanks,
Oscar

comment:4 Changed 5 years ago by annette

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.