Opened 5 years ago

Closed 4 years ago

#1456 closed help (fixed)

Segmentation Fault in an 8.4 job with user created SST/Sea Ice Ancils

Reported by: pliojop Owned by: annette
Component: UM Model Keywords: Ancils
Cc: Platform: ARCHER
UM Version: 8.4

Description

Hi,

I have copied an existing 8.4 UM job that I know runs (xkmwb) and added into it my own Anciliaries for SSTs and Sea Ice. This job is xkmwc.

My aim, is to create a year of 12 months of SST and Sea Ice data, which then repeats for every year of the job, so that I have identical SST/Sea Ice forcings throughout my simulation length (~50 years target).

Everytime I have tried to set the job to run, it crashes after about 1 minute with a Segmentation Fault. I have tried a variety of things, such as

In xancil

  • Having "create well formed ancils" ticked to both yes and no
  • Setting the year to be 0000, 1981 (year in UMUI), 1990 (year in start dump)
  • Setting the day to be both 1 and 15, adjusting the "define monthly mean to be the middle of the month" as appropriate.

General xancil settings are for Vn8.4 and the create ancils open in xconv. They have the same header names as the Ancil used to force xkwmb.

In the UMUI

  • I have ensured that the Sea Ice and SST Ancil boxes are set to update every 1 months
  • I have played around with the run lengths incase it was an issue with repeating the same 12 months of data.

I am now at somewhat of a loss with what to try next. For a previous ticket that Grenville helped with, I have chmod'd my directories so they should be readable.

My xancil general settings are saved as:

/home/n02/n02/japope/Ancils/xancil_set_up_NCAS_Ticket.job

I know from my leave files that the ancils are being found and opened by the model, but the model is then seg faulting out. As the only change between the job that runs fine (xkmwb) and the job that fails (xkmwc) is these ancils, I can only conclude they are at fault.

Thanks

James

Change History (4)

comment:1 Changed 4 years ago by pliojop

Hi

I am still having issues with this. I had found an issue with the Land Sea Masks, and resolved this, but the job now runs until resulted in the error:

REPLANCA: PP Headers on ancillary file do not match.

However, I have used pumf and certainly both dates match in the ticket.

Delving further through the leave file I see that there is an error:

INANCILA
warning code -17
Incorrect structure for ancillary file 18

I have opened my ancil files in xconv, they have the correct unit dimensions, the dates match in pumf.

I am really at a loss to explain these errors, any help would be much appreciated, as this is providing a block on my work at present.

Cheers

James

comment:2 Changed 4 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

James,

Is this still an issue?

Annette

comment:3 Changed 4 years ago by pliojop

Hi Annette,

Sorry, I should have closed the ticket, the problem has now been resolved.

Cheers

James

comment:4 Changed 4 years ago by annette

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.