Opened 5 years ago

Closed 5 years ago

#1478 closed help (fixed)

SSH Authentication Issues PUMA to Archer

Reported by: pliojop Owned by: um_support
Component: PUMA Keywords: ssh, authentication
Cc: Platform: PUMA
UM Version: <select version>

Description

Hi,

I logged in to PUMA today and when I tried to submit a job it asked me for my passphrase to transfer to Archer. I entered this correctly, but the job failed to submit stating in the ext.out file "permission denied (public key, keyboard-interactive)."

I tried ssh-add and got the message

"Could not open a connection to your authentication agent."

I re-ran the steps here https://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/Ros/sshAgent to see if I had corrupted a file or something, but the same problem persists. I logged out and logged in again, it still remains.

Have you any suggestions?

Change History (3)

comment:1 Changed 5 years ago by pliojop

  • Summary changed from SSH Authentican Issues PUMA to Archer to SSH Authentication Issues PUMA to Archer

comment:2 Changed 5 years ago by pliojop

I have now been able to fix this problem.

I deleted my environment.puma file, logged out, logged back in and ssh-add fixed the issue.

Thanks

comment:3 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

See also FAQ: Resolving ssh errors

Note: See TracTickets for help on using tickets.