Opened 5 years ago

Closed 5 years ago

#1486 closed help (answered)

Starting the UM from a different date

Reported by: mbollasi Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.8

Description

Hello,

we have a UM atmosphere dump from a previous simulation (xhipq - you can see it in $WORK/um/start_dumps) that finished in 1995 that we would like to use as our start dump. We would like to start our job (xlaxb) from 1998. We thought that we could switch on the reconfiguration, and the switches to override the date in the dump, to do this. The model runs the rcf step and seems to complete okay, but in the run step it crashes, complaining of "REPLANCA: Current time precedes start time of data". So we think we perhaps have missed a switch somewhere. Can you advise?

(we have realised we did not initially switch on "Enable build of UM scripts", which we have now switched on and will try using; could this be the cause of the issue?)

best regards,

Oliver & Massimo

Change History (6)

comment:1 Changed 5 years ago by annette

Oliver and Massimo,

You can use the change_dump_date tool to change the year in the dump file. See #1319

Regards,
Annette

comment:2 Changed 5 years ago by mbollasi

Hello Annette,

thank you for your reply. We made a copy of the dump and used the tool to change the date in that new dump..

/work/n02/n02/mbollasi/um/start_dumps/xlaxba.daj8c10

As the previous ticket points out, within xconv it still appears to show the 'wrong' date, so we don't have a way to be sure, but a diff suggests that we have at least changed something about the file.

We then resubmitted our job, this time with the reconfiguration off, as we thought this dump would now be at the desired start point. That did not work, see:

/home/n02/n02/mbollasi/output/xlaxb000.xlaxb.d15054.t160725.leave

returning the same error message as before.

We will now try again, this time using the 'new' dump again but with reconfiguration switched on. Perhaps that will work. What is not clear is what we are _supposed_ to do?

Massimo and Oliver

comment:3 Changed 5 years ago by annette

Hi Massimo,

I'm afraid I can't see your files. You'll need to change the permissions on your home and work spaces:

chmod -R g+rX /home/n02/n02/mbollasi
chmod -R g+rX /work/n02/n02/mbollasi

From what you have said, you should not need to reconfigure. To check that the date has been changed correctly, you can use the uminfo tool which prints the header information, for example:

uminfo filename | less 

Header elements 28 to 34 are the model basis time that the UM will use.

Each field in the file also has a date associated with it, and these are what is displayed by xconv, but they are not used to initialise the UM.

Annette

For reference:

There is a list of the common UM file tools here: http://cms.ncas.ac.uk/wiki/ToolsAndUtilities/UmFileTools

The UM file header format is specified in UMDP F3: http://cms.ncas.ac.uk/wiki/Docs/MetOfficeDocs

comment:4 Changed 5 years ago by mbollasi

Hello Annette,

thanks for that. We've used uminfo to check the file headers, and they do indeed show our desired start point (1998/12/1). We started a run with those restart files and other SST/Sea Ice files (/work/n02/n02/bdong/ancil/mon_hadsst_1946to1993_n96 and mon_hadice_1946to1993_n96, respectively) and the model runs. These files contain climatological sst and sea ice.
Thus it appears that the error is in our (monthly-varying) SST and Sea ice ancillaries files (/work/n02/n02/mbollasi/ancils/sst_and_seaIce/sst.1997_2010HadISST2.1 and ice.1997_2010HadISST2.1).
We cannot figure out what is wrong with them. Is it something related to the start point (i.e. SST and sea ice start from 1997)?

Thanks.

Massimo

comment:5 Changed 5 years ago by annette

Hi Massimo,

It looks like the dates in your new ancillaries are from 2000 to 2013 (I checked this in xconv and uminfo) so that would be why it's failing.

Annette

comment:6 Changed 5 years ago by annette

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.