Opened 4 years ago

Closed 4 years ago

#1539 closed error (answered)

UM run error, Error in routine: inbounda

Reported by: fadzilmnor Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.5

Description

Hi,
I've look at the same error message in this ticket (http://cms.ncas.ac.uk/ticket/1207) , but I'm not sure if it is the same issue.
The error message I got (see /home/n02/n02/py015531/output/xkynf000.xkynf.d15104.t152317.leave) :

??????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!?
? Error in routine: inbounda
? Error Code:     2
? Error Message: CHK_LOOK_BOUNDA : Wrong number of LBC fields
? Error generated from processor:     0
? This run generated  10 warnings
??????????????????????????????????????????????????????????????????????????

I'm not sure where to look at.

Fadzil

Attachments (1)

MyLBCfields.jpg (124.9 KB) - added by willie 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by willie

comment:1 Changed 4 years ago by willie

Hi Fadzil,

It looks like your LBC creation hasn't worked properly. The dumps you're using contain the right data, but it hasn't appeared in the LBC. I think you should repeat the LBC generation and keep the log file. You should submit to the serial queue. Include

#PBS -W umask=0022

in the header and then others will be able to read the log file. The log file will give a clue to what's going on.

As an aside, it is not necessary to use a sequence of start dumps to generate an LBC file. A single start dump will do. You just need to run a global model with the LBC STASH macro enabled as I suggested in #1438.

I have attached an example of the fields in one of my LBC files - this has rain, which you might not need.

Regards

Willie

comment:2 Changed 4 years ago by fadzilmnor

Hi Willie,
I'm trying to use the file : run_makebc
and I am not sure what to put in the RUNID here.


# Make sure any symbolic links are resolved to absolute path
export PBS_O_WORKDIR=$(readlink -f $PBS_O_WORKDIR)

# Change to the directory that the job was submitted from
cd $PBS_O_WORKDIR

export MAKEBC=/home/n02/n02/grenvill/makebc
export NAMELIST=/work/n02/n02/py015531/makebc/makebc_MalaysiaMay2012_12km.nl

RUNID=xlbha
cd $DEVTDIR/$RUNID
export LBC_FILE=./$RUNID.alabcou1_1

#
# perform makebc
#
# Get a list of the dumps
set $(ls -1 ${RUNID}a_cb*)
DUMPS=/work/n02/n02/py015531/dumps

$MAKEBC -n $NAMELIST -i $DUMPS -ow $LBC_FILE
if test $? -eq 0 ; then
 echo "makeBC successful"
else
 echo "Makebc failed"
fi

The other seems OK, but failed on locating this:

error:

ls: cannot access xlbhaa_cb*: No such file or directory

I may have missed something here. The file is definitely not exist.

Fadzil

comment:3 Changed 4 years ago by fadzilmnor

Hi Willie,
I've adjusted the namelist and wrapper files accordingly based on the MakeBC Documentation Paper F54, and waiting to test if it's working. Different from the comment above.

Fadzil

comment:4 Changed 4 years ago by willie

  • Resolution set to answered
  • Status changed from new to closed

Closed as no further response.

Note: See TracTickets for help on using tickets.