Opened 5 years ago

Closed 5 years ago

#1548 closed help (fixed)

Authentification error - public keyboard warning

Reported by: Leighton_Regayre Owned by: ros
Component: ARCHER Keywords:
Cc: Platform: ARCHER
UM Version: 8.4

Description

During umui submission, extraction fails because of what looks to be an authentication error.

I'm directed to the file:
/home/Leighton_Regayre/um/um_extracts/xljia/baserepos/UMATMOS/ext.out
in the tail of which there is a 'Permission Denied' error with the following in brackets:
publickey,keyboard-interactive

I've previously set my passphrase and submitted jobs during the UKCA_Tutorial. I've checked that my public key is within my ARCHER authorised keys file.

Thanks.

Change History (9)

comment:1 Changed 5 years ago by grenville

Leighton

We see sporadic ssh errors like the one you report - have you simply tried again.

Please conform that you can ssh to archer from the puma command line.

I just changed the name of your project - please use n02-FREEPPE.

Grenville

comment:2 Changed 5 years ago by Leighton_Regayre

Grenville,

Thanks for changing the project name. I've altered the job to match.

Yes, I did try a few times yesterday and again this morning with the same error resulting.

I can ssh onto ARCHER from PUMA command line.

The information provided when submitting the job is:

Extracting UMATMOS base repository…
UMATMOS base repository extract failed
See extract output file /home/Leighton_Regayre/um/um_extracts/xljia/baserepos/UMATMOS/ext.out
MAIN_SCR: Extract failed
MAIN_SCR stopped with return code 25

Your job directory on host login.archer.ac.uk is: /home/n02/n02/lre/umui_runs/xljia-119081732
umui_runs/xljia-119081732/SUBMIT[29]: .[5]: .[369]: .: line 72: PROMPT_COMMAND: is read only

Last edited 5 years ago by Leighton_Regayre (previous) (diff)

comment:3 Changed 5 years ago by ros

Hi Leighton,

Can you try running the following command on PUMA (It's the one that is failing see the ~/um/um_extracts/xljia/baserepos/UMATMOS/ext.out file):

ssh -n -oBatchMode=yes lre@login.archer.ac.uk mkdir -p /home/n02/n02/lre/um/xljia/baserepos/UMATMOS/cfg

That should work successfully. If it does please try submitting your job again and see if that helps.

Regards,
Ros.

comment:4 Changed 5 years ago by Leighton_Regayre

Hi Ros,

I'm getting a permission denied error when I run that command. Is this a passphrase related error?

Thanks,

Leighton

comment:5 Changed 5 years ago by ros

Hi Leighton,

You said in response to Grenville you can login (ssh) from PUMA to ARCHER from the command line, can you confirm whether or not it is asking for your passphrase or password please?

Cheers,
Ros.

Last edited 5 years ago by ros (previous) (diff)

comment:6 Changed 5 years ago by Leighton_Regayre

Hi Ros,

Yes I have been able to ssh to ARCHER from the PUMA command line and it requests my password only.

I've been using ssh -l lre lre@… to login.

Submitting via the umui requests my passphrase.

Thanks,

Leighton.

comment:7 Changed 5 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Leighton,

Ok, so we need to get your ssh-agent back up and running so you are not prompted for a password or passphrase. Can you please try running ssh-add on PUMA to reattach your ssh-key to the agent. Hopefully it will prompt for your passphrase, and after entering it you should then be able to login in to ARCHER without prompt for password/passphrase. If you get the response Could not open a connection to your authentication agent please follow the instructions on the FAQ to resolve it: http://cms.ncas.ac.uk/wiki/FAQ_T4_F5

Regards,
Ros.

comment:8 Changed 5 years ago by Leighton_Regayre

Thanks Ros. My submission is working now.

comment:9 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Great. Thanks for letting us know. I shall close this ticket now.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.