Opened 4 years ago

Closed 4 years ago

#1561 closed help (answered)

Cannot find machine.cfg for archer in SVN - Job Fails

Reported by: tt282 Owned by: grenville
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.6

Description

Dear all,

We are having problems executing our job. As the log below shows we hit a problem with SVN. SVN cannot find the archer machine.cfg. We have set our job up as a qsub job.

Calling MAIN_SCR - local…
(This may take several minutes.)

MAIN_SCR: Calling Extract …
Extracting UMATMOS base repository…
UMATMOS base repository extract failed
See extract output file /home/tt282xlkya/baserepos/UMATMOS/ext.out
MAIN_SCR: Extract failed
MAIN_SCR stopped with return code 25

umui_runs/xlkya-132121244/SUBMIT[16]: .: /home/n01/n01/tob282/.profile: cannot open [No such file or directory]

[FAIL] svn://puma/UM_svn/UM/trunk/src/configs/machines/cray-xc30-cce-archer/machine.cfg@14056: cannot locate config file, abort at /home/fcm/fcm-2015.03.0/bin/../lib/FCM1/ConfigSystem.pm line 539.

Change History (2)

comment:1 Changed 4 years ago by grenville

Tobia

I can't find /home/tt282xlkya/baserepos/UMATMOS/ext.out

I can't find the umui experiment xlky (I do see your extract directory 'though), so I am struggling to know how to help. Have you deleted the umui job or have you hidden it?

Grenville

comment:2 Changed 4 years ago by grenville

  • Resolution set to answered
  • Status changed from new to closed

xlkl deleted
Job xlldb exhibits the same problem

Looking in your PUMA /home/tt282/um/um_extracts/xlldb/baserepos/UMATMOS/ext.out
I can see the problem is because you haven’t specified the ncas branches and configurations that are needed
to run on ARCHER. Full details on what changes are needed to convert Met Office/MONSooN job to run on
ARCHER are available here: http://cms.ncas.ac.uk/wiki/Faq/ConvertMonsoonJobToArcher

The bit I can immediately see you are missing is this:

FCM Configuration → FCM Options for UM Atmos and Recon:
Bindings Location: Set to fcm:um_br/dev/um/vn8.6_machine_cfg/src/configs/bindings

Container File name and Location: $UM_SVN_BIND/container.cfg@vn8.6_cfg
Use different version of UM code base: set to vn8.6

Add the following branch to the "User Modifications" Table:
Add fcm:um_br/pkg/Config/vn8.6_ncas/src and place a Y in the last column.

Note: See TracTickets for help on using tickets.