Opened 5 years ago

Closed 4 years ago

#1576 closed help (fixed)

Archiving problem UMvn7.7

Reported by: sara123fenech Owned by: ros
Component: UM Model Keywords:
Cc: Platform: MONSooN
UM Version: 7.7

Description

Hi

I am currently trying to set archiving to work on a job which works on Monsoon (UM version 7.7) however nothing seems to work. I have managed to set up archiving to work on version 7.3 but not 7.7

The job id is xlhcx having .leave file:

xlhcx000.xlhcx.d15148.t144749.leave

Any suggestions why archiving is not working? Also is there any documentation which I could refer to for this particular version as to how to set up archiving please?

Thanks for your help
Sara

Change History (9)

comment:1 Changed 5 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Sara,

A change was made to the moose interface a while ago and this has not been applied to the vn7.7 code. Obviously no-one else is using archiving with vn7.7. We will get this change applied to the archiving branch and will get back to you once this has been done.

Regards,
Ros.

comment:2 Changed 5 years ago by ros

Hi Sara,

Please go to UMUI window Post processing → Main switch + General questions and enter your MONSooN Project group.

I've merged in the required changes to Jeff's branch. Please rebuild the UM scripts.

I've not been able to test the changes fully, so please let me know if you still encounter problems.

Regards,
Ros.

comment:3 Changed 5 years ago by sara123fenech

Hi Ros

Thanks a lot for making the required changes. I have resubmitted the job as an nrun this time including my project name (ukca) in the umui. As I do so I get the following error outputted:

Internal Inconsistency 

SYSTEM WARNING: Internal inconsistency while checking variable PROJECTGROUP. Please report. In the meantime this warning will not affect the editing of your job.SYSTEM WARNING: Internal inconsistency while checking variable FF2PP_NERC. Please report. In the meantime this warning will not affect the editing of your job.

I submitted the job just the same but archiving does not work. The job id is still xlhcx with .leave file:

xlhcx000.xlhcx.d15152.t095059.leave

Thanks a lot for your help

Regards
Sara

comment:4 Changed 5 years ago by ros

Hi Sara,

I have fixed the UMUI internal inconsistency and also made a couple of other changes to enable the PROJECTGROUP to be passed through to the UM scripts. It' s now being output to the post-processing control file so hopefully will work now. Please give it another go.

Regards,
Ros.

comment:5 Changed 5 years ago by sara123fenech

Hi Ros

I gave it another try. The inconsistency error has now gone however archiving still does not work. The new .leave file is xlhcx000.xlhcx.d15152.t163622.leave

Thanks Again
Sara

comment:6 Changed 5 years ago by ros

Hi Sara,

I've found the missing bit of code in the archiving scripts. There is no need to recompile your model executables so you can switch that off and just rebuild the UM scripts by switching on Enable build of UM scripts in window Compilation & modifications → UM Scripts Build.

I have run a test job and successfully archived to MASS.

Regards,
Ros.

comment:7 Changed 4 years ago by sara123fenech

Hi Ros

Just to let you know that archiving worked for me too. Thanks a lot for your help

Regards
Sara

comment:8 Changed 4 years ago by sara123fenech

Hi Ros

Just to let you know that archiving worked for me too. Thanks a lot for your help

Regards
Sara

comment:9 Changed 4 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.