Opened 5 years ago

Closed 5 years ago

#1580 closed error (fixed)

qsexecute not found

Reported by: ee10hp Owned by: annette
Component: UM Model Keywords:
Cc: gmann Platform: ARCHER
UM Version: 7.3

Description

Hello,

I'm trying to get my job xkzsa up and running on ARCHER. The base job xjnjn was originally ported to ARCHER from Monsoon by Karthee Sivalingam.

The main changes I have made from the base job have been to 1)change from crun to nrun and 2) add meteorological nudging.

My simulation has crashed on ARCHER with the following error message

/work/n02/n02/ee10hp/um/xkzsa/bin/qsexecute[844]: /usr/sbin/mknod: not found [No such file or directory]
qsexecute: mknod fails to create pipe to archiving system

Please see the output file /home/n02/n02/ee10hp/output/xkzsa000.xkzsa.d15149.t103518.leave

Please can you advise me on how to proceed?

I see a related ticket (#1521) has been answered in the past but I'm not sure how to apply it to my job as I am unable to edit anything in Compilation & Run options → UM scripts build.

I submitted the job after fs2 and fs4 came back into service so I don't expect that's the problem.

Many thanks,
Hannah

Change History (4)

comment:1 Changed 5 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hannah,

Your job is set up to compile which means it should build the UM scripts anyway. This is why you can't select the option.

Did the build step succeed OK? And were you able to run the base job before you added in the nudging?

If you can change the permissions on your directories on Archer then I'll take a look:

chmod -R g+rX /home/n02/n02/ee10hp
chmod -R g+rX /work/n02/n02/ee10hp

Best regards,
Annette

comment:2 Changed 5 years ago by ee10hp

Hi Annette,

Thanks for your reply. I've now changed those directory permissions.

How do I check if the build has worked please?
I didn't check the base job before but I know it's worked for other users. I've now submitted the base job as a nrun to do a personal check (job xkzsy)- I'll do this before making changes to any base jobs in the future.

I used these instructions to apply the nudging: http://www.ukca.ac.uk/wiki/index.php/Nudging#Getting_Working_at_UM7.3

Thanks for your help,
Hannah

comment:3 Changed 5 years ago by annette

Hi Hannah,

I think you need to have the Archer archiving branch included in your job.

Go to FCM Configuration → FCM Options for Atmosphere and Reconfiguration. Switch off the following branch by changing the 'Y' to 'N':

fcm:um-br/pkg/Share/VN7.3_HadGEM3-A_r2.0/src

And add in this branch:

fcm:um_br/dev/jeff/VN7.3_HadGEM3-A_r2.0_hector_monsoon_archiving/src

Leave the revision number blank and add 'Y' in the 'Use' column.

Then resubmit and hopefully it will work.

Annette

comment:4 Changed 5 years ago by ee10hp

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks Annette, that's fixed it!
Hannah

Note: See TracTickets for help on using tickets.