Opened 5 years ago

Closed 4 years ago

#1583 closed help (fixed)

Running on ARCHER - umui settings

Reported by: pringle Owned by: ros
Component: UM Model Keywords:
Cc: Platform:
UM Version: 8.4

Description

Hi,

I've copied a job from someone and I'm just adapting it to run from my account. I'm getting the following error when I submit:

umui_runs/xlmub-155130104/SUBMIT[29]: .[31]: .[369]: .: line 72: PROMPT_COMMAND: is read only
eslogin004

(the full output is below).

I guess I'm missing permission to run, probably because there is I have missed a change in the umui where the paths are set to run on my account, but I can't see it.

The jobID is xlmub

Thanks for your help,
Kirsty

Calling MAIN_SCR - local…
(This may take several minutes.)

MAIN_SCR: Calling Extract …
Extracting UMATMOS base repository…
UMATMOS base repository extract is OK
Extracting JULES base repository…
JULES base repository extract is OK
Extracting UMSCRIPTS including any branches…
UMSCRIPTS extract is OK
Extracting UMATMOS including any branches…
UMATMOS extract is OK
Extracting UMRECON including any branches…
UMRECON extract is OK
MAIN_SCR: Extract OK
MAIN_SCR: Submit OK

ModuleCmd_Load.c(226):ERROR:105: Unable to locate a modulefile for 'netcdf'

Your job directory on host login.archer.ac.uk is: /home/n02/n02/pringle/umui_runs/xlmub-155130104

umui_runs/xlmub-155130104/SUBMIT[29]: .[31]: .[369]: .: line 72: PROMPT_COMMAND: is read only
eslogin004
Total PEs requested: 144
NOTE: The following has been selected for running on the CRAY XC30

144 MPI task(s)
12 node(s)
12 MPI task(s) per node
2 OpenMP thread(s) per task

Change History (5)

comment:1 Changed 5 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Kirsty,

The ERROR from the module load is because you must have a module load netcdf in either your .profile or .bashrc on ARCHER. This has now needs to be module load cray-netcdf.

The PROMPT_COMMAND is read-only can be ignored. This and other variables can be listed and is a result of some changes ARCHER made a while ago.

Looking at the output you have supplied there is a bit missing between the MAIN_SCR: Extract OK and MAIN_SCR: Submit OK which should detail a login to ARCHER and the qsub job number, so I am surmising there is an ssh issue.

Could you please close down the UMUI, run export UMUI_SSH_DEBUG_LEVEL=5 on the PUMA command line, restart the UMUI and resubmit your job. You will then see a lot of ssh output to your terminal window. Could you copy and paste this into a file on PUMA somewhere and let me know where that file is please?

Regards,
Ros.

comment:2 Changed 4 years ago by pringle

Hi Ros,

Thanks, I've changed the netCDF command.

I've put the output to the sumbit command here: /home/pringle/File_For_Ros

Now you mention it, it doesn't ask me for my passwords when I submit, which it should normally do. So I think you're right about the ssh settings.

Thanks for your help,
Kirsty

comment:3 Changed 4 years ago by ros

Hi Kirsty,

This one had me going for a while. Your ssh is working fine. You have ssh-keys set up so it is correctly logging in without asking for a password which is necessary. The problem is due to the hand_edit manual_comp_ARCHER.ed. This is stopping the automatic submitting of the job to the queue for compilation. You will need to turn this hand_edit off for it to submit properly. You might want to talk to the person you copied the job from, as there may be a reason why they were manually submitting this job to the queues.

Cheers,
Ros.

comment:4 Changed 4 years ago by pringle

Ah! Yes, that makes sense. The person I copied it from is doing ensemble simulations so will need to do manual submissions. I didn't realize that he'd added in a hand_edit for this. I'm just doing a few testing simulations, so I can use the umui.

I'll give it a go with this turned off,

Many thanks!

Kirsty

comment:5 Changed 4 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.