Opened 4 years ago

Closed 4 years ago

#1606 closed error (fixed)

UM seg faults on ARCHER: "requested and actual threading level different"

Reported by: peatman Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.2

Description

I'm currently unable to run the UM on ARCHER as the job always seg faults after a few moments, e.g. see /home/n02/n02/peatman/output/xkgug000.xkgug.d15182.t161623.leave The key bit of error output seems to be the following:

WARNING - REQUESTED AND ACTUAL THREADING LEVEL DIFFERENT
THREAD LEVEL REQUESTED is MPL_THREAD_MULTIPLE
THREAD LEVEL SET is MPL_THREAD_SERIALIZED
Enabling  0 I/O PEs
Application 16078685 exit codes: 137
Application 16078685 resources: utime ~72s, stime ~4s, Rss ~10808, inblocks ~137030, outblocks ~453244
0+1 records in
0+1 records out
1405 bytes (1.4 kB) copied, 0.00127847 s, 1.1 MB/s
0+0 records in
0+0 records out
0 bytes (0 B) copied, 0.000278917 s, 0.0 kB/s

I've been able to run the model in the past but it hasn't worked at all this week, and I'm not sure what I've changed which could have caused the problem.

Thanks,
Simon

Change History (3)

comment:1 Changed 4 years ago by grenville

Simon

Your build on July 1st was not a full build - please force a full rebuild FCM Configuration→ FCM Extract directories… then check Force FULL Build.

Uncheck it for subsequent incremental builds

Grenville

comment:2 Changed 4 years ago by peatman

Grenville,

I've now got it working - thanks for your help.

Simon

comment:3 Changed 4 years ago by peatman

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.