Opened 4 years ago

Closed 3 years ago

#1617 closed help (answered)

several problems in getting started with Rose and UM10.0

Reported by: till Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: PUMA
UM Version: 10.1

Description

I'm doing my first steps with Rose now. I'm following the instructions:
http://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooNRose

  1. There's a quirk though when I work on the Puma repository. Even though I've set up .subversion/servers as recommended, when I run e.g. rosie ls or rosie go, there's a tiny window popping up that asks me for the username for 'u'. Even if I click cancel, the window comes back (3x overall). Eventually though, the proper results of rosie ls are given. What should I make of that?
  1. I'm also wondering which repository to use eventually, puma or exvmsrose (the shared repository). I'd think it'd be the shared one eventually, but currently many more UKESM jobs are on the puma repository?
  1. When I start rose edit on puma (in my suite dir, puma-aa177), I get an error message that says:

Could not find metadata for /home/jwalto/repository/vn10.0_postproc_moopath/rose-meta/archive_and_meaning/postproc/HEAD

But then rose edit opens the window and I can go ahead and work on the configuration. Do I need to worry about that?

  1. I'm trying to do a short test run of puma-aa177 which is a copy of puma-aa127. However it doesn't work at first attempt. If I run rose suite-run on puma, I get this:
    till@puma:/home/till/roses/puma-aa177> rose suite-run
    [INFO] create: log.20150723T144113Z
    [INFO] delete: log
    [INFO] symlink: log.20150723T144113Z <= log
    [INFO] log.20150723T143804Z.tar.gz <= log.20150723T143804Z
    [INFO] delete: log.20150723T143804Z/
    [INFO] create: log/suite
    [INFO] create: log/rose-conf
    [INFO] symlink: rose-conf/20150723T154113-run.conf <= log/rose-suite-run.conf
    [INFO] symlink: rose-conf/20150723T154113-run.version <= log/rose-suite-run.version
    [INFO] export CYLC_VERSION=6.4.1
    [INFO] export ROSE_ORIG_HOST=puma
    [INFO] export ROSE_VERSION=2015.04.1
    [INFO] install: app
    [INFO]     source: /home/till/roses/puma-aa177/app
    [FAIL] cylc validate -v --strict puma-aa177 # return-code=1, stderr=
    [FAIL] 'The initial cycle point:19780901T0000Z is after the final cycle point:19780822T0000Z.'
    

Not quite sure what happens here. I admit that I chose 'false' for the compilation for UM and NEMO, and I set the run length to 1 day.

  1. In rose edit (for puma-aa177), where can I set that I don't want to run UKCA and the full JULES, but just the UM and NEMO?
  1. Where can I set the paths for the executables (UM, recon, NEMO)?

Thanks a lot for your support!

Change History (3)

comment:1 Changed 4 years ago by till

Hi there,
I got some hints (from MOHQ) for tackling (1) through (4) in the above. I'll tackle that tomorrow (= Friday). I realize I need to work on exvmsrose rather than on puma.

Still would be great if you could say something regarding (5) and (6).

Thank you

comment:2 Changed 3 years ago by ros

Answered by another channel. For reference the answers are:

  1. This happens if your MOSRS password is not cached properly using gpg-agent. If you just want to view suites in the PUMA repository then you can run rosie go --prefix=puma.
  1. The preference is to use the MOSRS rosie-u repository to store suites. The puma suite repository was created in the beginning before the MOSRS one came on-line and as a test system. We expect everyone to migrate their suites to the MOSRS rosie-u repository eventually. The puma suites repository will remain for any suites that need to be kept private and for test purposes.
  1. You get this error when suites refer to non-standard metadata. It is safe to go ahead and edit teh suite, it just means that some settings/switches will be displayed in raw format rather than with associated help or in a named panel, etc.
  1. This error message occurs if you set the total run length to be less than the cycling frequency.
  1. In this suite the UKCA switch is in Section 34: l_ukca and to switch off JULES you need to remove the def UM_JULES=um_jules in panel fcm_make_um → env → Preprocessing
  1. Rose suites expect the executables to be in cylc-run/share/<app>/build/bin

comment:3 Changed 3 years ago by ros

  • Resolution set to answered
  • Status changed from new to closed
  • UM Version changed from <select version> to 10.1
Note: See TracTickets for help on using tickets.