Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1635 closed help (fixed)

Problems with auto-archiving from v7.3 nudged HADGEM3-UKCA jobs on ARCHER. (Follow-on from ticket #1058?)

Reported by: ee10hp Owned by: um_support
Component: UM Model Keywords: archiving UKCA units
Cc: gmann Platform: ARCHER
UM Version: 7.3

Description

Dear NCAS-CMS helpdesk,

Thank you for your help.
I am having some problems with the automatic post-processing and archiving on the ARCHER /nerc disk space with my v7.3 nudged HadGEM3-UKCA jobs (e.g. job ID xkzsd).Superseded restart dumps aren't being automatically deleted and the model output is also not being sent over to my /nerc disk space.

I have set up the auto-archiving correctly I think as per these instructions (http://cms.ncas.ac.uk/wiki/Archer/NercArchiving).

I noticed that Graham Mann raised a similar helpdesk ticket (#1058, now fixed/closed) a couple of years ago to report problems archiving on HECTOR.

I think the same solution may apply to my problem - That is that two UKCA subroutines (fastj_inphot and fastjx_inphot) are reading a file on unit 8, which I think is required by the archiving system. So it looks like I need to change the unit number to a different number that isn't being used by the UM.

Can you please suggest a unit number that I can use for this? Or please can you advise me on how to find out which units are not being used by the UM?

My .leave file is also here if you think there may be another cause:
/home/n02/n02/ee10hp/output/xkzsd000.xkzsd.d15229.t115428.leave

(Please note this particular job is only running for a few months before crashing but it is producing output for those months so I can see that the auto-archiving isn't working).

Many thanks for your help,
Hannah

Change History (4)

comment:1 Changed 4 years ago by annette

Hi Hannah,

I suspect you are right about this. You can see in the leave file which units the UM uses (by searching for "unit") as the model prints a message when it reads or writes to a file. However I don't know which unit numbers UKCA uses, so you may need to look at the code.

Annette

comment:2 Changed 4 years ago by ee10hp

Hi Annette,

Thanks for your help. I changed the unit in those UKCA subroutines and the auto-archiving is now working.

Thanks,
Hannah

comment:3 Changed 4 years ago by annette

  • Resolution set to fixed
  • Status changed from new to closed

Great thanks for letting us know.

Annette

comment:4 Changed 4 years ago by annette

  • Keywords archiving UKCA units added
Note: See TracTickets for help on using tickets.