Opened 4 years ago

Closed 3 years ago

#1655 closed help (answered)

using rose, gcylc on exvmsrose and vn10.2 on cray

Reported by: markr Owned by: um_support
Component: UM Model Keywords: rose bush cylc gcylc
Cc: Platform: MONSooN
UM Version: 10.2

Description

Hello,
I have moved onto to using vn10.2 and exvmsrose (and exvmscylc) with xcm.
I have successfully run a rose-suite (u-aa411) and I am developing
u-aa547 a copy of u-aa411.

I wonder how iam supposed to view the rose-bush?
I made a change to source nd ran u-aa547 a second time and it worked okay.
I could tell my changes to the namelist were included as I put a print statement in the source.

However, now I made a second change and the suite fails. How do I interrogate using Gcylc?
I tried following http://cms.ncas.ac.uk/wiki/RoseCylc but
the firefox command (issued on exvmsrose) did not connect to anything.

Hope there is a simple solution.

Change History (4)

comment:1 Changed 4 years ago by ros

Hi Mark,

Sorry, rose-bush is currently broken on exvmsrose, the Met Office will fix this at some point.

The alternatives for viewing the log files are:

1) Using Gcylc. You can view the output & error logs by right clicking on the failed task and select view → job stdout, job stderr, etc.

2) Or you can view the log files in $HOME/cylc-run/suite-id/log/….

Cheers,
Ros.

Last edited 4 years ago by ros (previous) (diff)

comment:2 Changed 4 years ago by annette

Hi Mark,

I have just had an update from the FCM team at the Met Office. Apparently there is some system issue with Rose bush on exvmsrose at the moment, but the MONSooN team are aware and looking into it.

Regards,
Annette

comment:3 Changed 4 years ago by ros

  • Status changed from new to pending

comment:4 Changed 3 years ago by annette

  • Resolution set to answered
  • Status changed from pending to closed
  • UM Version changed from 8.6 to 10.2

Hi Mark,

I have just chased this up, and Rose Bush will now work on exvmsrose through firefox. See email below from Ben Fitzpatrick of the FCM team.

Annette


Rose Bush is running on exvmsrose, although I think the 'rose suite-log' command doesn't bring it up.

If you launch 'firefox' on that server, you can go to e.g.

http://localhost/rose-bush/suites?user=aospre

and it works OK.

rose suite-log doesn't launch anything because it looks like Python's webbrowser.py doesn't work on MONSooN. At least for X-over-SSH it doesn't. it tries to run the command:

firefox -raise -remote 'openURL(http://localhost/rose-bush/list/aospre/u-ab685,new-window)'

which, if run outside Python, falls over with:

Error: No running window found

Ben

Note: See TracTickets for help on using tickets.