Opened 4 years ago

Closed 4 years ago

#1673 closed help (answered)

"Rosie go" crashing at start-up on exvmsrose

Reported by: gmann Owned by: ros
Component: UM Model Keywords: rose GUI
Cc: markr Platform: MONSooN
UM Version: 10.2

Description

Dear NCAS-CMS helpdesk,

Earlier this evening I was able to successfully submit a UM v10.2
suite from MONSOON exvmsrose (u-aa411 — a 2-day job with GA6 N96L85 UKCA CheST+GLOMAP).

When I "rose suite-run" it submitted OK and the gcylc GUI came up OK and the job eventually compiled, reconfigured and ran.

I tracked down the equivalent of the .leave file at:

~/cylc-run/u-aa411/log/job/1/atmos/01/job.out

and found the "built code" at:

~/cylc-run/u-aa411/share/fcm_make/extract/um/src

so I thought all was working fine.

However, when I typed "rosie go" to open the rose GUI I got "MainWindow?" "display_box" error message as below. It looks like it was failing to set something associated with the window or maybe this is a symptom of some other problem with the PUMA repository?

I don't know if I have something not quite set up right or else maybe this error is a general problem at the current time.

This weekend there seems to be a problem even to open the UMUI on PUMA (I raised separate ticket about this Friday night) and I'm wondering if this error with "rosie go" might be being caused by the same issue?

Please can you advise if this is a general issue or something I have not quite set up right.

Thanks
Graham

grmann@exvmslander:~]$ ssh -Y exvmsrose
WARNING:
This computer is provided for the processing of official information.
Unauthorised access described in Met Office SyOps? may constitute a criminal offence.
All activity on the system is liable to monitoring.
Last login: Sun Sep 27 18:51:31 2015 from 10.168.6.1


This is exvmsrose.monsoon-metoffice.co.uk
Red Hat Enterprise Linux Server release 6.4 (Santiago)


Met Office Science Repository Service password:
Subversion password cached
https://code.metoffice.gov.uk/rosie/u/hello: Hello grahammann
Rosie password cached
[grmann@exvmsrose:~]$ rosie go
[WARN] http://puma.nerc.ac.uk/rosie/puma/get_known_keys: None: Max retries exceeded with url: /rosie/puma/get_known_keys?format=json (Caused by redirect)
Traceback (most recent call last):

File "/home/fcm/rose-2015.06.0/lib/python/rosie/browser/main.py", line 994, in handle_update_treemodel_local_status

self.display_box.update_treemodel_local_status(local_suites,

AttributeError?: 'MainWindow?' object has no attribute 'display_box'
81@14410

Change History (3)

comment:1 Changed 4 years ago by ros

Hi Graham,

Sorry, we've only just seen this ticket as you assigned it to yourself, so we didn't get alerted to it. Please leave the "owned by" set to <default> and the system will fill it in automatically.

On Saturday PUMA rebooted itself due to a brief disruption in power and thus both the UMUI and web services went down until restarted on Monday. This would have meant that rosie go would have been unable to see the PUMA suite repository hence the crash you saw.

It's working ok for me now, I assume it is ok for you now too?

It would have been helpful if it could have error'ed in a nice way rather than crash so may look into that at some stage or pass to the Met Office Rose team.

Regards,
Ros.

Last edited 4 years ago by ros (previous) (diff)

comment:2 Changed 4 years ago by ros

  • Owner changed from gmann to ros
  • Status changed from new to accepted

comment:3 Changed 4 years ago by annette

  • Resolution set to answered
  • Status changed from accepted to closed

I am closing this ticket, but have added the untidy failure to a list of Rose issues to investigate/pass back to the developers.

Annette

Note: See TracTickets for help on using tickets.