Opened 11 years ago

Closed 5 years ago

#168 closed help (fixed)

6 hourly FAMOUS output variables are separated into several ones

Reported by: m.yoshioka@… Owned by: jeff
Component: FAMOUS Keywords: FAMOUS outputs
Cc: r.s.smith@… Platform:
UM Version: <select version>

Description

6 hourly FAMOUS output variables should have 120 time steps in a monthly output file like var(120). But each of those variables is actually stored in several different variables like var(60), var_1(30), var_2(26), var_3(3), and var_4(1). This is how it looks in a converted NetCDF file. In original files viewed with xconv the same variables are simply repeated and they have timesteps of 60, 30, …. This happened in the pj files of my job tcmis:
quest-hpc.bristol.ac.uk:/exports/gpfsbig/home/ggxmy/dump2hold/tcmis/datam/tcmisa#pj0000290????+

I wrote an IDL script to connect these variables into one and output a fixed NetCDF file, so I'm Ok with working with it for now. But this may be a problem when I run simulations where I will have to use many of these data. But before that this is not the way it should work. So I ask for a help for this issue.

Thanks.
Masaru

Change History (4)

comment:1 Changed 11 years ago by robin

  • Cc r.s.smith@… added
  • Owner changed from famous_support to jeff

Jeff - this is the xconv/convsh issue I mentioned this week (I'm not pestering, we're just trying to get FAMOUS users to use the helpdesk properly!). I've put a couple of the tcmisa* files he mentions locally in /home/robin

I'm pretty sure the problem is to do with the large date in the files. If I hack the tcmisa* to bring the year stamps (FIXHDR(21), FIXHDR(28), LOOKUP(1,*), LOOKUP(7,*)) into the 0-9999 range xconv reads the files correctly again (~robin/tcmisa#pj000029060dc+-HACK)

thanks!

comment:2 Changed 9 years ago by lois

  • Resolution set to fixed
  • Status changed from new to closed
  • UM Version set to <select version>

comment:3 Changed 9 years ago by lois

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 5 years ago by annette

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.