Opened 2 years ago

Closed 2 years ago

#1706 closed help (fixed)

Segmentation Fault

Reported by: webber24 Owned by: willie
Priority: normal Component: UM Model
Keywords: ancillary Cc:
Platform: ARCHER UM Version: 8.4

Description

Dear CMS,

This is an issue very similar to ticket #1598http://cms.ncas.ac.uk/ticket/1598, but I tried the solution suggested, yet to no avail. I have the following error message, when attempting to run job xldgt:

mkdir:: File exists
Application 18509732 is crashing. ATP analysis proceeding…

ATP Stack walkback for Rank 12 starting:

bi_linear_h_@…:516

ATP Stack walkback for Rank 12 done
Process died with signal 11: 'Segmentation fault'
Forcing core dumps of ranks 12, 0, 1
View application merged backtrace tree with: stat-view atpMergedBT.dot
You may need to: module load stat

The changes I have made to this job, following a previous job that would run are:
1) Added SST, Sea Ice and Ozone ancillaries - There are no nan values (have cumf'ed them) and the land masks match up.
2) Changed the date to 2050 and the run length to 10 years.

The .leave file is: xldgt000.xldgt.d15299.t102235.leave and in my output directory in ARCHER.

(The previous job was xldgq)

Many Thanks,

Chris

Change History (3)

comment:1 Changed 2 years ago by willie

  • Keywords ancillary added
  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Chris,

Your job fails to converge at time step 3 and then generates NaNs?. A failure at this early stage usually indicates a problem with the initial fields. I tried a run with sst and sea ice set to "not used" and this worked (see my xlzam, which uses your xlgdq exec). I checked the initial data for NaNs? and they are OK. So I am guessing that these ancillary files, together, were generated using a land sea mask that is slightly different from the one used in the your model - this is detailed in the Ancil > In file > Ancillary version files.

So I think you need to re-create these ancillary files and also create a land sea mask ancillary too and use this for all (in Ancil > Other > Land sea mask).

Regards

Willie

Last edited 2 years ago by willie (previous) (diff)

comment:2 Changed 2 years ago by webber24

Hi Willie,

This worked, it seemed that the files I used to create SST and Sea Ice anomaly values had a different land sea mask to those entered originally in the model.

Thanks for your help!

You may close this ticket now

comment:3 Changed 2 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.