#1716 closed help (fixed)

vn7.3 AO CICE headers on Monsoon

Reported by: dcw32 Owned by: annette
Priority: normal Component: NEMO/CICE
Keywords: Cc:
Platform: MONSooN UM Version: 7.3

Description

Hi,

I'm currently using the vn7.3 AO coupled to stratospheric chemistry on Monsoon. I was hoping to get some help with the CICE headers. I've managed to get the modify_CICE_header.f90 to compile with the intel compiler using the '-convert big_endian' option, it runs and seems to create the file with the modified header. However running with this file then comes up with an error:

lib-4001 : UNRECOVERABLE library error
  A READ operation tried to read past the end-of-file.

Encountered during a sequential unformatted READ from unit 15
Fortran unit 15 is connected to a sequential unformatted  file:
  "/projects/ukca-cam/dawad/start_dumps/xlzeyi.restart.2829-01-01-00000_reset"
Application 192713 is crashing. ATP analysis proceeding...

This was model run xlzex (leave file at ~dawad/output/xlzex000.xlzex.d15307.t073202.leave, modify_CICE_header at ~dawad and input files xlzeyi.restart.2829-01-01-00000 and xlzeyi.restart.2829-01-01-00000_reset, with the modified headers at /projects/ukca-cam/dawad/start_dumps). I chmod +rx ed my home and project directories.

Any help to get this working would be greatly appreciated.

Many thanks,

David

Change History (7)

comment:1 Changed 18 months ago by dcw32

Looking at #1667, I've had a go at backporting the changes from fcm:um-br/jwalton/vn8.2_NEMOCICE_restart_fixes_UKMO and fcm:cice-br/dev/jwalton/vn4.1m1_restart_date_fix_UKMO to vn7.3 UM (to /scripts/control/qscicesetup) and vn4.0 CICE (to /source/ice_age.F90) to job xlzey.

Diffs for xlzex to xlzey:
ice_age.F90

220,221c220,221
<       use ice_calendar, only: sec, month, mday, nyr, istep0, istep1, &
<                               dt, time, time_forc, idate, year_init
---
>       use ice_calendar, only: sec, month, mday, nyr, istep1, &
>                               time, time_forc, idate, year_init
261,264d260
<           ! Over-ride time information with what we need to avoid date problems
<           istep1=istep0
<           time=istep0*dt
<           time_forc=time

& qscicerun

151,152d150
<   CICE_AGE_REST=`grep ' , restart_age * =' ice_in|awk -F ' ' {'print $4'}|awk -F '.' {'print $2'}`
< 
174c172
<   , runtype        = '$CICE_RUNTYPE'
---
>   , runtype        = 'continue'
320,331c318,319
< #   ICE_IC=$CICE_START
< #   RESTART=.true.
<     if [[ "$CICE_AGE_REST" = "true" ]]
<     then
<       CICE_RUNTYPE=continue
<       ICE_IC='set_in_pointer_file'
<       echo $CICE_START > ice.restart_file
<     else
<       CICE_RUNTYPE=initial
<       ICE_IC=${CICE_START}
<     fi
<     RESTART='.true.'
---
>    ICE_IC=$CICE_START
>    RESTART=.true.
334d321
<    CICE_RUNTYPE=initial

But the dates of the output files aren't correct. I don't know anything about CICE so some advice about how best to proceed would be great!

comment:2 Changed 18 months ago by annette

David,

Where did you get the modify_CICE_header code from? Was it copied from the IBM? I think I have seen the utility on the internal Met Office HPC so we may be able to copy exec from there.

Also I notice that the file xlzeyi.restart.2829-01-01-00000_reset is smaller than xlzeyi.restart.2829-01-01-00000:

-rw-r--r-- 1 dawad users 11082684 Nov  2 07:49 xlzeyi.restart.2829-01-01-00000
-rw-r--r-- 1 dawad users 10656428 Nov  3 07:25 xlzeyi.restart.2829-01-01-00000_reset

Did you check the value of oceanmixed_ice was correct? Or perhaps the program has not worked properly.

Regards,
Annette

comment:3 Changed 18 months ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

comment:4 Changed 18 months ago by dcw32

Hi Annette,

I'm not 100% sure, it might have been from one of your folders actually! I tried using convert='big_endian' when opening the file, both Cray and Intel compilers and no matter what options I select when running the executable seem to result in the smaller file being output. So I suspect it's just not working properly.

If there's a working version and it can be made available that would be great!

Many thanks,

David

comment:5 Changed 18 months ago by annette

David,

The code you copied was my attempt to port the code, which I had abandoned. For reference, there was an error in the code related to the oceanmixed_ice switch, and the compile flags were wrong (so no wonder it didn't work!) It builds with the cray compiler but requires loading craype-ivybridge for the login nodes.

Anyway the working version can be found here:

~aospre/bin/modify_CICE_header

I have tested this on your file: xlzeyi.restart.2829-01-01-00000 resetting istep0, time and time_forc to 0, and this seems to work OK with a copy of your job. The new file is here:

/projects/umadmin/aospre/test/cice/xlzeyi.restart.2829-01-01-00000_reset_2

Note that I set oceanmixed_ice to be true, although it is false in the job namelist. I don't quite understand this but it works.

Annette

comment:6 Changed 18 months ago by dcw32

Annette,

I've run a couple of jobs using the script and everything seems to be working perfectly. Thanks a lot for your help!

Cheers,

David

comment:7 Changed 18 months ago by annette

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.