Opened 2 years ago

Closed 23 months ago

#1720 closed help (fixed)

Issue with IAU file in a UMUI job

Reported by: sam89 Owned by: willie
Priority: normal Component: UM Model
Keywords: IAU Cc:
Platform: MONSooN UM Version: 8.2

Description

Hi

I am having trouble including a IAU perturbation file into a UM run.
I created a perturbation file and added it to the run as an IAU file however when I run the job an error shows in the .leave file saying that the time I have input into the UMUI window doesn't match the time in the perturbation file.
The perturbation file is for 18Z and the time I put in the IAU start to end (in minutes) reflects this. I have also tried changing the time to starting before 18Z and finishing before 19Z (as I am trying to input the perturbation over an hour window) but again the same error occurs.
To my knowledge the headers in the perturbation files are correct so I was wondering if anyone knew why this may not be working still?
The job ID is xkfys with the reconfig job for the run being xkfyc and the build job is xkfya

many thanks
Sam

Change History (5)

comment:1 Changed 2 years ago by willie

  • Keywords IAU added
  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Sam,

In your latest leave file for xkfys, you're getting the error,

? Error in routine: Setup_IAU
? Error Code:     1
? Error Message: Validity time of first IAU increment outside IAU period

The set up of the IAU is described on UMDP 31 at NCAS CMS web site.

Also, your first increments file, /projects/diamet/saclar/perturbed_fields_anc.pp, seems to be all zeroes. I don't know if this was intentional.

Regards,

Willie

comment:2 Changed 2 years ago by willie

Hi Sam,

OK I think it is because you specified the insertion period as start (=2012-07-05 0Z) plus 1050 mins to start+1110 mins and your start dump (2012-07-05 0Z) is before this. You need a start dump 2012-07-05 18Z, which you could by running the model forward first and then using the output dump in this run xkfys.

Regards

Willie

comment:3 Changed 2 years ago by sam89

Hi Willie

I now reran the job using an 18Z start dump however I am getting the exact same error still as I did when using the 00Z start dump. I have changed the insertion period of 0 - 60 minutes after the start of the run. The start dump and perturbation files now match up.

Thanks

Sam

comment:4 Changed 2 years ago by willie

Hi Sam,

The problem is with the perturbation file /projects/diamet/saclar/perturbed_fields_anc.pp. The data time is 2012-07-05 18Z, but the validity time is zero. You can see this using umifo: the data time is in header 21-25 (Year, month, day, hour min) and the validity time is in headers 28-32.

The code computes the time difference between the validity time and the basis time (= data time) and gets an enormous number so that it looks like perturbations start a long time after the insertion interval.

The solution is to recreate the perturbations file with a validity time the same as the start time.

PS: you have set the model to CRUN - it should be a NRUN first. Also you could reduce the number of processor to 6x16, so it uses less resources and will not queue as long.

Regards,

Willie

comment:5 Changed 23 months ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.