Opened 2 years ago

Closed 2 years ago

#1723 closed help (fixed)

obtaining latest xconv / convsh

Reported by: iwi Owned by: jeff
Priority: normal Component: UM Tools
Keywords: Cc:
Platform: Other UM Version: <select version>

Description

We are using and distributing xconv / convsh at CEDA. Currently we have 1.92 and I have discovered some segfault problems (see https://github.com/cedadev/jasmin_scivm/issues/39). I have tried convsh on oak, which I see has 1.93, and it works fine with the same PP file that causes problems with our 1.92 installation. Is there a proper place we should get copies of 1.93 please? Or should I just copy the executables off oak, and if so, are we allowed to redistribute them? I would like at least to put the latest x86_64 executable in the JAP, and preferably to be informed of any further updates.

We also distribute some executables via https://badc.nerc.ac.uk/help/software/xconv/ which is somewhat out of date. (It claims the latest is 1.91.) Ideally I think that CMS should host a download page and that we should just put a prominent link at the top of that page to the relevant page at CMS rather than attempting to keep track of further updates ourselves.

Apologies if I have missed something obvious.

Thanks,
Alan

Change History (4)

comment:1 Changed 2 years ago by iwi

P.S. of course we would also be interested in having the source if it can be compiled simply with a top-level build script rather than a lot of efforts with dependencies. I think I was given an earlier version of the source, which I attempted to use as the basis of our RPMs for JAP, but I gave up and just wrapped Jeff's binaries in an RPM. Thanks.

comment:2 Changed 2 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Alan

There is some updated documentation and a download section available here, http://cms.ncas.ac.uk/documents/xconv/. This is linked on the relevant page on the CMS wiki and there is a news item about it on the CMS home page (http://cms.ncas.ac.uk/). There is no problem including the executable in the JAP or linking to the download page from the BADC page. Building from source is just as difficult as before so just including the executable is probably the best idea.

Jeff.

comment:3 Changed 2 years ago by iwi

Jeff,

Thanks for that.

Alan

P.S. Having tried it out, I have a separate issue unrelated to the version upgrade, which I will raise in another ticket.

comment:4 Changed 2 years ago by iwi

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.