#1728 closed error (fixed)

Insufficient space in Bsend buffer

Reported by: kz821407 Owned by: um_support
Priority: high Component: UM Model
Keywords: Bsend buffer Cc:
Platform: ARCHER UM Version: 8.6

Description

Hi,

I am trying to extend my domain size for my idealised simulation but I keep getting this error.

An error occured inside the MPI library during an operation
on the communicator: model
MPI_COMMUNICATOR= -1006632960 MPI_ERROR_CODE= 134860801 aborting…
Invalid buffer pointer, error stack:
MPI_Bsend(192)…….: MPI_Bsend(buf=0x7fffee1e82e0, count=4922112, MPI_BYTE, dest=9, tag=109, comm=0xc4000000) failed
MPIR_Bsend_isend(347): Insufficient space in Bsend buffer; requested 4922112; total buffer size is 32000000

I was wondering whether you would be able to help me understand why this is happening?

Thanks,
Carly

Change History (3)

comment:1 Changed 22 months ago by grenville

Carly

The problem is in the perturbation code — please try using Peter's code in

UM/branches/dev/pclark/vn8.6_idealized/src/atmosphere/dynamics_advection/idl_random_perturb.F90

Maybe check w/Peter in case you can use the whole branch (it does have a lot changes 'though)

Grenville

comment:2 Changed 22 months ago by grenville

Probably simplest to check out Peter's branch (UM/branches/dev/pclark/vn8.6_idealized) and then copy the code —just to confirm you are working at M 8.6?

Grenville

comment:3 Changed 21 months ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.