#1747 closed help (fixed)

ff2pp

Reported by: sam89 Owned by: ros
Priority: normal Component: UM Tools
Keywords: ff2pp Cc:
Platform: MONSooN UM Version:

Description (last modified by ros)

Hi Ros

I am having problems using ff2pp since the switch over to CRAY. I think it could be due to my setup now not being right. Could you possibly take a look at why it won't work for me?

Many thanks

Sam Clarke

Change History (7)

comment:1 Changed 17 months ago by ros

  • Description modified (diff)
  • Owner changed from um_support to ros
  • Status changed from new to accepted

comment:2 Changed 17 months ago by ros

Hi Sam,

Could you send me:

1) the command you are running
2) What directory you are running it from
3) Any error messages

Cheers,
Ros.

Last edited 17 months ago by ros (previous) (diff)

comment:3 Changed 17 months ago by ros

Well I tried doing
which ff2pp and it says

saclar@xcml00:~> which ff2pp
which: no ff2pp in (/opt/pbs/12.2.401.141761/bin:/opt/cray/mpt/7.0.4/gni/bin:/opt/cray/atp/1.7.5/bin:/opt/cray/rca/1.0.0-2.0502.60530.1.62.ari/bin:/opt/cray/alps/5.2.4-2.0502.9774.31.11.ari/sbin:/opt/cray/dvs/2.5_0.9.0-1.0502.2188.1.116.ari/bin:/opt/cray/xpmem/0.1-2.0502.64982.5.3.ari/bin:/opt/cray/pmi/5.0.5-1.0000.10300.134.8.ari/bin:/opt/cray/ugni/6.0-1.0502.10863.8.29.ari/bin:/opt/cray/udreg/2.3.2-1.0502.10518.2.17.ari/bin:/opt/cray/craype/2.2.1/bin:/opt/cray/cce/8.3.4/cray-binutils/x86_64-unknown-linux-gnu/bin:/opt/cray/cce/8.3.4/craylibs/x86-64/bin:/opt/cray/cce/8.3.4/cftn/bin:/opt/cray/cce/8.3.4/CC/bin:/opt/cray/switch/1.0-1.0502.60522.1.61.ari/bin:/opt/cray/eslogin/eswrap/1.1.0-1.020200.1231.0/bin:/opt/modules/3.2.10.3/bin:/opt/python/gnu/2.7.9/bin/:/opt/ukmo/mass/moose-monsoon-client-latest/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin:/sbin:/usr/sbin:/usr/lib/qt3/bin:/opt/ukmo/supported/bin/:/opt/cray/bin)

I located ff2pp in /projects/um1/vn8.2/cray/utils

saclar@xcml00:/projects/um1/vn8.2/cray/utils> ff2pp /projects/diamet/saclar/xkfyo/xkfyo.pp3 /projects/diamet/saclar/xkfyo/Global_IAU_day4.pp
If 'ff2pp' is not a typo you can run the following command to lookup the package that contains the binary:
    command-not-found ff2pp
-bash: ff2pp: command not found

So I am pretty sure it is something to do with the setup in my .profile file as to why it won't work. I know I need to add the /projects/um1/vn8.2/cray/utils to my .profile file but when I try to open my .profile file it just keeps saying 'resource temporarily unavailable' and therefore I am unable to look at the file or add to it. I tried it on Friday too and it said the same thing. Do you think I should just re make my .profile file?

Thanks

Sam

comment:4 Changed 17 months ago by ros

Hi Sam,

Please try using $UMDIR/bin/ff2pp

Please do also let me know if you are able to edit other files in your $HOME directory, and I will then investigate the 'resource temporarily unavailable' problem.

Cheers,
Ros.

comment:5 Changed 17 months ago by ros

There was a problem with the ff2pp under $UMDIR/vn8.2/cray/utils/ff2pp which I have now fixed. It had VRN set to 8.6 and thus referencing the 32 bit execs under UM8.6 which don't exist.

comment:6 Changed 17 months ago by ros

  • Reporter changed from ros to sam89

comment:7 Changed 17 months ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Further updates from email:-

Hi Sam,

I've spoken to the MONSooN team about your .profile problem and apparently a problem with the NFS mounts a while ago caused a few incidents where people had created a file on one system and it disappeared off another. This could be an explanation.

Anyway, AJ has retrieved your .profile.
Please try copying it into your $HOME directory and fingers crossed the system allows you to do this.

Regards,
Ros.


Hi Ros

Thanks for finding out about this/ sorting it for me - much appreciated!

It seems to have copied across ok and I can open it/ read it fine now.

Many thanks

Sam

Note: See TracTickets for help on using tickets.